summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-17 07:18:33 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-17 07:18:33 +0000
commitc78fcd93ecf195b5111afe933c42e3f3f7ec365f (patch)
tree97c542ce3923bd3e7ef1f8c2ffdd4580a5f01798 /dev-ruby
parentsci-libs/coot-data: Bump to EAPI=5 (diff)
downloadgentoo-2-c78fcd93ecf195b5111afe933c42e3f3f7ec365f.tar.gz
gentoo-2-c78fcd93ecf195b5111afe933c42e3f3f7ec365f.tar.bz2
gentoo-2-c78fcd93ecf195b5111afe933c42e3f3f7ec365f.zip
Version bump. Add additional dependencies listed in the gemspec.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/jeweler/ChangeLog9
-rw-r--r--dev-ruby/jeweler/jeweler-1.8.6.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-ruby/jeweler/ChangeLog b/dev-ruby/jeweler/ChangeLog
index 306c050c59f0..5d60c922da9a 100644
--- a/dev-ruby/jeweler/ChangeLog
+++ b/dev-ruby/jeweler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/jeweler
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jeweler/ChangeLog,v 1.20 2012/09/27 10:28:16 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jeweler/ChangeLog,v 1.21 2013/07/17 07:18:33 graaff Exp $
+
+*jeweler-1.8.6 (17 Jul 2013)
+
+ 17 Jul 2013; Hans de Graaff <graaff@gentoo.org> +jeweler-1.8.6.ebuild:
+ Version bump. Add additional dependencies listed in the gemspec.
27 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> jeweler-1.8.4.ebuild:
Keyword ~ppc wrt #432830
diff --git a/dev-ruby/jeweler/jeweler-1.8.6.ebuild b/dev-ruby/jeweler/jeweler-1.8.6.ebuild
new file mode 100644
index 000000000000..30b0ea311fb8
--- /dev/null
+++ b/dev-ruby/jeweler/jeweler-1.8.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jeweler/jeweler-1.8.6.ebuild,v 1.1 2013/07/17 07:18:33 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC="-Ilib yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+# Tests and features also need the same set of dependencies present.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.markdown README.markdown"
+
+RUBY_FAKEGEM_GEMSPEC="jeweler.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rake tasks for managing gems and versioning and a generator for creating a new project"
+HOMEPAGE="http://wiki.github.com/technicalpickles/jeweler"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+ruby_add_rdepend "dev-ruby/bundler dev-ruby/nokogiri dev-ruby/highline dev-ruby/rdoc dev-ruby/builder dev-ruby/rake"
+
+# We do not depend on all runtime dependencies since the usage of jeweler in
+# Rakefile's does not require this. However, the generator does, but it
+# depends on gems that are obsolete and not supported in Gentoo.
+
+all_ruby_prepare() {
+ # Remove bundler support.
+ rm Gemfile || die
+ sed -i -e '/bundler/d' -e '/Bundler.setup/d' Rakefile test/test_helper.rb features/support/env.rb || die
+
+ # Remove (currently) unused targets from the Rakefile that require
+ # additional dependencies.
+ sed -i -e '/rcov/,$d' Rakefile || die
+
+ # Remove a runtime dependency that we can't satisfy.
+ sed -i -e '/github_api/d' jeweler.gemspec || die
+}