summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-11-07 06:25:56 +0000
committerHans de Graaff <graaff@gentoo.org>2010-11-07 06:25:56 +0000
commit9b06d1c39c2b8927d548420b27d474eecb6ef715 (patch)
tree635ff9eb1454f7d0946f24a293cc393d6db93b36 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-9b06d1c39c2b8927d548420b27d474eecb6ef715.tar.gz
gentoo-2-9b06d1c39c2b8927d548420b27d474eecb6ef715.tar.bz2
gentoo-2-9b06d1c39c2b8927d548420b27d474eecb6ef715.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/patron/ChangeLog7
-rw-r--r--dev-ruby/patron/patron-0.4.10.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ruby/patron/ChangeLog b/dev-ruby/patron/ChangeLog
index 8a69e2509371..c99d9ab98e4c 100644
--- a/dev-ruby/patron/ChangeLog
+++ b/dev-ruby/patron/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/patron
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.6 2010/10/22 14:57:15 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.7 2010/11/07 06:25:56 graaff Exp $
+
+*patron-0.4.10 (07 Nov 2010)
+
+ 07 Nov 2010; Hans de Graaff <graaff@gentoo.org> +patron-0.4.10.ebuild:
+ Version bump.
22 Oct 2010; Christian Faulhammer <fauli@gentoo.org>
patron-0.4.9-r1.ebuild:
diff --git a/dev-ruby/patron/patron-0.4.10.ebuild b/dev-ruby/patron/patron-0.4.10.ebuild
new file mode 100644
index 000000000000..6b3464183b3f
--- /dev/null
+++ b/dev-ruby/patron/patron-0.4.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/patron-0.4.10.ebuild,v 1.1 2010/11/07 06:25:56 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION.yml"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl."
+HOMEPAGE="http://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/jeweler )"
+#ruby_add_bdepend "test? ( dev-ruby/jeweler dev-ruby/rspec )"
+
+DEPEND="${DEPEND} net-misc/curl"
+RDEPEND="${RDEPEND} net-misc/curl"
+
+# Tests require a live web service that is not included in the distribution.
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron || die
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}