summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-28 08:20:31 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-28 08:20:31 +0000
commit8fff8a80647947722df40c3a2a7d5872d19bd864 (patch)
tree29722ab72bc95349d202c4e406ff09a6efe4c1ed /dev-ruby
parentDrop ~ia64-linux (diff)
downloadgentoo-2-8fff8a80647947722df40c3a2a7d5872d19bd864.tar.gz
gentoo-2-8fff8a80647947722df40c3a2a7d5872d19bd864.tar.bz2
gentoo-2-8fff8a80647947722df40c3a2a7d5872d19bd864.zip
Version bump with various bug fixes. Drop patches applied upstream.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/oauth/ChangeLog7
-rw-r--r--dev-ruby/oauth/oauth-0.4.4.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-ruby/oauth/ChangeLog b/dev-ruby/oauth/ChangeLog
index e09d9b8a5a5d..59fbe603a1ba 100644
--- a/dev-ruby/oauth/ChangeLog
+++ b/dev-ruby/oauth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/oauth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.12 2010/11/01 20:58:13 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.13 2010/12/28 08:20:31 graaff Exp $
+
+*oauth-0.4.4 (28 Dec 2010)
+
+ 28 Dec 2010; Hans de Graaff <graaff@gentoo.org> +oauth-0.4.4.ebuild:
+ Version bump with various bug fixes. Drop patches applied upstream.
01 Nov 2010; Hans de Graaff <graaff@gentoo.org> -oauth-0.4.1.ebuild:
Remove old version.
diff --git a/dev-ruby/oauth/oauth-0.4.4.ebuild b/dev-ruby/oauth/oauth-0.4.4.ebuild
new file mode 100644
index 000000000000..e91506e6f7a7
--- /dev/null
+++ b/dev-ruby/oauth/oauth-0.4.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/oauth-0.4.4.ebuild,v 1.1 2010/12/28 08:20:31 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="HISTORY README.rdoc TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A RubyGem for implementing both OAuth clients and servers."
+HOMEPAGE="http://oauth.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit
+ >=dev-ruby/actionpack-2.3.8:2.3
+ dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ # Let this test work with a wider range of rails versions, but still
+ # in SLOT 2.3, and request the right version of rack for it.
+ sed -i -e "s/'2.3.8'/'~>2.3.8'/" test/test_action_controller_request_proxy.rb || die
+
+ # Ensure a consistent test order to avoid loading issues with e.g. rack
+ sed -i -e "s/.rb']/.rb'].sort/" Rakefile || die
+}