summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2010-01-01 13:56:05 +0000
committerAlex Legler <a3li@gentoo.org>2010-01-01 13:56:05 +0000
commit442c1fe5e3fb891f27fe73bfc208a5b5d84e611b (patch)
treee602313bc5c3112d4698e70cbb6a62af231e871a /dev-ruby
parentstable x86, bug 299203 (diff)
downloadgentoo-2-442c1fe5e3fb891f27fe73bfc208a5b5d84e611b.tar.gz
gentoo-2-442c1fe5e3fb891f27fe73bfc208a5b5d84e611b.tar.bz2
gentoo-2-442c1fe5e3fb891f27fe73bfc208a5b5d84e611b.zip
Fix tests when rdoc is not yet installed (bug 298910), add test dependency on minitest, s/$PN/rdoc/ in HOMEPAGE
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rdoc/ChangeLog8
-rw-r--r--dev-ruby/rdoc/rdoc-2.4.3.ebuild16
2 files changed, 19 insertions, 5 deletions
diff --git a/dev-ruby/rdoc/ChangeLog b/dev-ruby/rdoc/ChangeLog
index da4f939be144..d199d935c10a 100644
--- a/dev-ruby/rdoc/ChangeLog
+++ b/dev-ruby/rdoc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/rdoc
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/ChangeLog,v 1.17 2009/12/30 18:43:09 graaff Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/ChangeLog,v 1.18 2010/01/01 13:56:05 a3li Exp $
+
+ 01 Jan 2010; Alex Legler <a3li@gentoo.org> rdoc-2.4.3.ebuild:
+ Fix tests when rdoc is not yet installed (bug 298910), add test dependency
+ on minitest, s/$PN/rdoc/ in HOMEPAGE
30 Dec 2009; Hans de Graaff <graaff@gentoo.org> rdoc-2.4.3.ebuild:
Use proper task name for USE=doc, partially fixing #298910.
diff --git a/dev-ruby/rdoc/rdoc-2.4.3.ebuild b/dev-ruby/rdoc/rdoc-2.4.3.ebuild
index b88cbbc9b923..4888daae8be7 100644
--- a/dev-ruby/rdoc/rdoc-2.4.3.ebuild
+++ b/dev-ruby/rdoc/rdoc-2.4.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/rdoc-2.4.3.ebuild,v 1.4 2009/12/30 18:43:09 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/rdoc-2.4.3.ebuild,v 1.5 2010/01/01 13:56:05 a3li Exp $
EAPI=2
USE_RUBY="ruby18 ruby19"
@@ -15,7 +15,7 @@ RUBY_FAKEGEM_BINWRAP=""
inherit ruby-fakegem
DESCRIPTION="An extended version of the RDoc library from Ruby 1.8"
-HOMEPAGE="http://rubyforge.org/projects/${PN}/"
+HOMEPAGE="http://rubyforge.org/projects/rdoc/"
SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
LICENSE="Ruby"
@@ -24,6 +24,7 @@ KEYWORDS="~amd64"
IUSE=""
ruby_add_bdepend test dev-ruby/hoe
+ruby_add_bdepend test virtual/ruby-minitest
ruby_add_bdepend doc dev-ruby/hoe
all_ruby_install() {
@@ -33,3 +34,12 @@ all_ruby_install() {
ruby_fakegem_binwrapper $bin $bin-2
done
}
+
+each_ruby_test() {
+ # `rake test' would fail when rdoc is not yet installed.
+ # Setting $rdoc_rakefile fixes this.
+ ${RUBY} -w -Ilib:ext:bin:test \
+ -e 'require "rubygems"; require "minitest/autorun"; \
+ $rdoc_rakefile = true; Dir.glob("test/test*.rb").each \
+ {|t| require t }' || die "Tests failed for ${RUBY}"
+}