summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-04-23 14:59:04 +0000
committerTom William Payne <twp@gentoo.org>2003-04-23 14:59:04 +0000
commit1f0cb9cd8451f09b44a692f8bd7942a6e42bb8e7 (patch)
tree2cd2c1bdb16bb87d6affb3ba55496e28dce748bf /dev-ruby/uconv
parenttouchups (diff)
downloadgentoo-2-1f0cb9cd8451f09b44a692f8bd7942a6e42bb8e7.tar.gz
gentoo-2-1f0cb9cd8451f09b44a692f8bd7942a6e42bb8e7.tar.bz2
gentoo-2-1f0cb9cd8451f09b44a692f8bd7942a6e42bb8e7.zip
Initial commit.
Diffstat (limited to 'dev-ruby/uconv')
-rw-r--r--dev-ruby/uconv/ChangeLog9
-rw-r--r--dev-ruby/uconv/uconv-0.4.11.ebuild23
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/uconv/ChangeLog b/dev-ruby/uconv/ChangeLog
new file mode 100644
index 000000000000..42ae725df0c9
--- /dev/null
+++ b/dev-ruby/uconv/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-ruby/uconv
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/uconv/ChangeLog,v 1.1 2003/04/23 14:59:04 twp Exp $
+
+*uconv-0.4.11 (23 Apr 2003)
+
+ 23 Apr 2003; Tom Payne <twp@gentoo.org> uconv-0.4.11.ebuild :
+
+ Initial version.
diff --git a/dev-ruby/uconv/uconv-0.4.11.ebuild b/dev-ruby/uconv/uconv-0.4.11.ebuild
new file mode 100644
index 000000000000..ba21323b68b5
--- /dev/null
+++ b/dev-ruby/uconv/uconv-0.4.11.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/uconv/uconv-0.4.11.ebuild,v 1.1 2003/04/23 14:59:04 twp Exp $
+
+DESCRIPTION="A module to convert ISO/IEC 10646 (Unicode) string and Japanese strings"
+HOMEPAGE="http://www.yoshidam.net/Ruby.html#uconv"
+SRC_URI="http://www.yoshidam.net/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND=">=dev-lang/ruby-1.6.7"
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ cp extconf.rb extconf.rb.orig
+ sed -e '/^\$CFLAGS = ""/d' extconf.rb.orig > extconf.rb
+ ruby extconf.rb || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}