summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-03-30 07:03:04 +0000
committerHans de Graaff <graaff@gentoo.org>2010-03-30 07:03:04 +0000
commit64a7eb82c5307da1f26f2eb06c490e763bdf3559 (patch)
tree436bea511bd32e62ca2c3f5f482de02f6c256204 /dev-ruby/tzinfo
parentFix for USE="python -tool" situation, #311995 (diff)
downloadgentoo-2-64a7eb82c5307da1f26f2eb06c490e763bdf3559.tar.gz
gentoo-2-64a7eb82c5307da1f26f2eb06c490e763bdf3559.tar.bz2
gentoo-2-64a7eb82c5307da1f26f2eb06c490e763bdf3559.zip
Version bump: Updated to tzdata version 2010g.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/tzinfo')
-rw-r--r--dev-ruby/tzinfo/ChangeLog7
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.18.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index 6a2a24829357..dff983207639 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.49 2010/03/17 07:20:07 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.50 2010/03/30 07:03:04 graaff Exp $
+
+*tzinfo-0.3.18 (30 Mar 2010)
+
+ 30 Mar 2010; Hans de Graaff <graaff@gentoo.org> +tzinfo-0.3.18.ebuild:
+ Version bump: Updated to tzdata version 2010g.
*tzinfo-0.3.17 (17 Mar 2010)
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.18.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.18.ebuild
new file mode 100644
index 000000000000..7c5a5f3d1ab1
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.18.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.18.ebuild,v 1.1 2010/03/30 07:03:04 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+ruby_add_bdepend test virtual/ruby-test-unit
+
+all_ruby_prepare() {
+ # The package has all the files executable, probably coming from
+ # Windows.
+ find "${S}" -type f -perm +111 -exec chmod -x {} +
+
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i -e '138,146s:^:#:' "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}