summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-19 05:59:30 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-19 05:59:30 +0000
commitbb752da411ad3870e52db7cc785b5bf46e5d3c6d (patch)
tree94fcebfc5e2e5bb5d73111c35748436ecd99b160 /dev-ruby/test-unit
parentVersion bump. (diff)
downloadgentoo-2-bb752da411ad3870e52db7cc785b5bf46e5d3c6d.tar.gz
gentoo-2-bb752da411ad3870e52db7cc785b5bf46e5d3c6d.tar.bz2
gentoo-2-bb752da411ad3870e52db7cc785b5bf46e5d3c6d.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog7
-rw-r--r--dev-ruby/test-unit/test-unit-2.4.0.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index d3281dfe9dc7..827561b57e94 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.42 2011/07/22 07:36:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.43 2011/09/19 05:59:30 graaff Exp $
+
+*test-unit-2.4.0 (19 Sep 2011)
+
+ 19 Sep 2011; Hans de Graaff <graaff@gentoo.org> +test-unit-2.4.0.ebuild:
+ Version bump.
*test-unit-2.3.0 (22 Jul 2011)
diff --git a/dev-ruby/test-unit/test-unit-2.4.0.ebuild b/dev-ruby/test-unit/test-unit-2.4.0.ebuild
new file mode 100644
index 000000000000..afb0e7852cbf
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-2.4.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.4.0.ebuild,v 1.1 2011/09/19 05:59:30 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
+
+# Disable default binwraps
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
+HOMEPAGE="http://test-unit.rubyforge.org/"
+
+LICENSE="Ruby"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ yard doc || die
+}
+
+each_ruby_test() {
+ # the rake audit using dev-ruby/zentest currently fails, and we
+ # just need to call the testsuite directly.
+ # rake audit || die "rake audit failed"
+ local rubyflags
+
+ [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
+
+ ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
+ # rdoc-2* series.
+ ruby_fakegem_binwrapper testrb /usr/bin/testrb-2
+}