summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-09-11 06:05:10 +0000
committerHans de Graaff <graaff@gentoo.org>2013-09-11 06:05:10 +0000
commitf7907ac49fc582401061dbe36f4ebf80328f6517 (patch)
tree716fbb15ad84d46aa335053bfa5d1e06cbeb3145 /dev-ruby/syntax
parentmark chromium-29 -arm as it's broken on arm, chromium-30 is okay (see bug #47... (diff)
downloadgentoo-2-f7907ac49fc582401061dbe36f4ebf80328f6517.tar.gz
gentoo-2-f7907ac49fc582401061dbe36f4ebf80328f6517.tar.bz2
gentoo-2-f7907ac49fc582401061dbe36f4ebf80328f6517.zip
API=5. Remove useless virtual/ruby-test-unit dependency. Run as much of the test suite as we can. Add ruby20.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/syntax')
-rw-r--r--dev-ruby/syntax/ChangeLog8
-rw-r--r--dev-ruby/syntax/syntax-1.0.0-r4.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/syntax/ChangeLog b/dev-ruby/syntax/ChangeLog
index c41236ed2315..d47c33acf5a5 100644
--- a/dev-ruby/syntax/ChangeLog
+++ b/dev-ruby/syntax/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/syntax
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syntax/ChangeLog,v 1.45 2013/09/04 13:24:59 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syntax/ChangeLog,v 1.46 2013/09/11 06:05:10 graaff Exp $
+
+*syntax-1.0.0-r4 (11 Sep 2013)
+
+ 11 Sep 2013; Hans de Graaff <graaff@gentoo.org> +syntax-1.0.0-r4.ebuild:
+ API=5. Remove useless virtual/ruby-test-unit dependency. Run as much of the
+ test suite as we can. Add ruby20.
04 Sep 2013; Manuel Rüger <mrueg@gentoo.org> -syntax-1.0.0-r2.ebuild:
Cleanup old.
diff --git a/dev-ruby/syntax/syntax-1.0.0-r4.ebuild b/dev-ruby/syntax/syntax-1.0.0-r4.ebuild
new file mode 100644
index 000000000000..99e2fddb7e5e
--- /dev/null
+++ b/dev-ruby/syntax/syntax-1.0.0-r4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syntax/syntax-1.0.0-r4.ebuild,v 1.1 2013/09/11 06:05:10 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Syntax highlighting for sourcecode and HTML"
+HOMEPAGE="http://syntax.rubyforge.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+all_ruby_prepare() {
+ # The yaml test case hangs. Remove it so we can at least run all
+ # other tests instead of skipping the whole test suite.
+ rm test/syntax/tc_yaml.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/ALL-TESTS.rb || die "tests failed"
+}