summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-06-22 05:37:34 +0000
committerHans de Graaff <graaff@gentoo.org>2015-06-22 05:37:34 +0000
commitde91fd83d822b571067b4af90c97d384c6db2f0b (patch)
tree3b9ae11348754d7f91eb6b0de211155b669a9a9b /dev-ruby/sprockets
parentStable for PPC64 (bug #552632). (diff)
downloadgentoo-2-de91fd83d822b571067b4af90c97d384c6db2f0b.tar.gz
gentoo-2-de91fd83d822b571067b4af90c97d384c6db2f0b.tar.bz2
gentoo-2-de91fd83d822b571067b4af90c97d384c6db2f0b.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/sprockets')
-rw-r--r--dev-ruby/sprockets/ChangeLog7
-rw-r--r--dev-ruby/sprockets/sprockets-3.2.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-ruby/sprockets/ChangeLog b/dev-ruby/sprockets/ChangeLog
index 52bee8bd19f3..e9c4bb50d51d 100644
--- a/dev-ruby/sprockets/ChangeLog
+++ b/dev-ruby/sprockets/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/sprockets
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sprockets/ChangeLog,v 1.35 2015/06/07 19:52:12 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sprockets/ChangeLog,v 1.36 2015/06/22 05:37:34 graaff Exp $
+
+*sprockets-3.2.0 (22 Jun 2015)
+
+ 22 Jun 2015; Hans de Graaff <graaff@gentoo.org> +sprockets-3.2.0.ebuild:
+ Version bump.
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-ruby/sprockets/sprockets-3.2.0.ebuild b/dev-ruby/sprockets/sprockets-3.2.0.ebuild
new file mode 100644
index 000000000000..0864668032b4
--- /dev/null
+++ b/dev-ruby/sprockets/sprockets-3.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sprockets/sprockets-3.2.0.ebuild,v 1.1 2015/06/22 05:37:34 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="sprockets.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Ruby library for compiling and serving web assets"
+HOMEPAGE="https://github.com/rails/sprockets"
+SRC_URI="https://github.com/rails/sprockets/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+ruby_add_rdepend "
+ =dev-ruby/rack-1*:*
+ !!<dev-ruby/sprockets-2.12.3-r1:2"
+
+ruby_add_bdepend "test? (
+ dev-ruby/json
+ dev-ruby/rack-test
+ =dev-ruby/coffee-script-2*
+ =dev-ruby/execjs-2*
+ =dev-ruby/sass-3* >=dev-ruby/sass-3.1
+ dev-ruby/uglifier
+ )"
+
+all_ruby_prepare() {
+ # Avoid tests for template types that we currently don't package:
+ # eco and ejs.
+ sed -i -e '/eco templates/,/end/ s:^:#:' \
+ -e '/ejs templates/,/end/ s:^:#:' test/test_environment.rb || die
+ sed -i -e '/.ejs/ s:^:#:' test/test_asset.rb || die
+ rm -f test/test_require.rb test/test_{closure,eco,ejs,yui}_{compressor,processor}.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e "s:ruby:${RUBY}:" test/test_sprocketize.rb || die
+}
+
+each_ruby_test() {
+ # Make sure we have completely separate copies. Hardlinks won't work
+ # for this test suite.
+ cp -R test test-new || die
+ rm -rf test || die
+ mv test-new test || die
+
+ each_fakegem_test
+}