summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-11 15:27:06 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-11 15:27:06 +0000
commit3d33029a155826393e80ede6d0428a55ab68f2c8 (patch)
tree0c57758c10ae16bf1379211860741389d7870371 /dev-ruby/ruby-ldap
parentClean up patch. (diff)
downloadgentoo-2-3d33029a155826393e80ede6d0428a55ab68f2c8.tar.gz
gentoo-2-3d33029a155826393e80ede6d0428a55ab68f2c8.tar.bz2
gentoo-2-3d33029a155826393e80ede6d0428a55ab68f2c8.zip
Cleanup old.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/ruby-ldap')
-rw-r--r--dev-ruby/ruby-ldap/ChangeLog6
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.9.13.ebuild44
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.9.15.ebuild44
3 files changed, 5 insertions, 89 deletions
diff --git a/dev-ruby/ruby-ldap/ChangeLog b/dev-ruby/ruby-ldap/ChangeLog
index 02c812af49a3..19487c852822 100644
--- a/dev-ruby/ruby-ldap/ChangeLog
+++ b/dev-ruby/ruby-ldap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ruby-ldap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-ldap/ChangeLog,v 1.61 2013/09/24 05:38:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-ldap/ChangeLog,v 1.62 2013/11/11 15:27:06 mrueg Exp $
+
+ 11 Nov 2013; Manuel Rüger <mrueg@gentoo.org> -ruby-ldap-0.9.13.ebuild,
+ -ruby-ldap-0.9.15.ebuild:
+ Cleanup old.
*ruby-ldap-0.9.16 (24 Sep 2013)
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.9.13.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.9.13.ebuild
deleted file mode 100644
index 9c1360b9d8a9..000000000000
--- a/dev-ruby/ruby-ldap/ruby-ldap-0.9.13.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-ldap/ruby-ldap-0.9.13.ebuild,v 1.1 2013/06/06 05:42:50 graaff Exp $
-
-EAPI=5
-# jruby: mkmf
-# rbx: require 'ldap' no such file to load
-USE_RUBY="ruby18 ruby19"
-
-inherit multilib ruby-fakegem
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_EXTRADOC="ChangeLog FAQ NOTES README TODO"
-
-DESCRIPTION="A Ruby interface to some LDAP libraries"
-HOMEPAGE="http://ruby-ldap.sourceforge.net/"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-macos"
-IUSE="ssl"
-DEPEND=">=net-nds/openldap-2
- dev-libs/cyrus-sasl
- ssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}"
-
-# Current test set is interactive due to certificate generation and requires
-# running LDAP daemon
-RESTRICT="test"
-
-each_ruby_configure() {
- local myconf="--with-openldap2"
- if ! use ssl ; then
- myconf="${myconf} --without-libcrypto --without-libssl"
- fi
- ${RUBY} extconf.rb ${myconf} || die "extconf.rb failed"
- sed -i -e 's:-Wl,--no-undefined::' \
- -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" Makefile || die
-}
-
-each_ruby_compile() {
- emake V=1 || die
- cp ldap$(get_modname) lib/ || die
-}
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.9.15.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.9.15.ebuild
deleted file mode 100644
index 053a507b9252..000000000000
--- a/dev-ruby/ruby-ldap/ruby-ldap-0.9.15.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-ldap/ruby-ldap-0.9.15.ebuild,v 1.1 2013/09/06 05:42:20 graaff Exp $
-
-EAPI=5
-# jruby: mkmf
-# rbx: require 'ldap' no such file to load
-USE_RUBY="ruby18 ruby19 ruby20"
-
-inherit multilib ruby-fakegem
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_EXTRADOC="ChangeLog FAQ NOTES README TODO"
-
-DESCRIPTION="A Ruby interface to some LDAP libraries"
-HOMEPAGE="http://ruby-ldap.sourceforge.net/"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-macos"
-IUSE="ssl"
-DEPEND=">=net-nds/openldap-2
- dev-libs/cyrus-sasl
- ssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}"
-
-# Current test set is interactive due to certificate generation and requires
-# running LDAP daemon
-RESTRICT="test"
-
-each_ruby_configure() {
- local myconf="--with-openldap2"
- if ! use ssl ; then
- myconf="${myconf} --without-libcrypto --without-libssl"
- fi
- ${RUBY} extconf.rb ${myconf} || die "extconf.rb failed"
- sed -i -e 's:-Wl,--no-undefined::' \
- -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" Makefile || die
-}
-
-each_ruby_compile() {
- emake V=1 || die
- cp ldap$(get_modname) lib/ || die
-}