summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-12-20 09:08:15 +0000
committerAlex Legler <a3li@gentoo.org>2009-12-20 09:08:15 +0000
commit2e3dee642119e3f32216d3bf165b926ccaccfcbb (patch)
tree702163d76d74b23f43e3825da912acb49d7950b5 /dev-ruby/rails
parentAdd ebuild for 4.0.249.43 beta release and add myself as a maintainer of chro... (diff)
downloadgentoo-2-2e3dee642119e3f32216d3bf165b926ccaccfcbb.tar.gz
gentoo-2-2e3dee642119e3f32216d3bf165b926ccaccfcbb.tar.bz2
gentoo-2-2e3dee642119e3f32216d3bf165b926ccaccfcbb.zip
Removing vulnerable versions
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog6
-rw-r--r--dev-ruby/rails/rails-2.2.3.ebuild47
-rw-r--r--dev-ruby/rails/rails-2.3.4.ebuild47
3 files changed, 5 insertions, 95 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index da699b83dfdf..30d4bf076577 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.164 2009/12/19 14:24:48 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.165 2009/12/20 09:08:15 a3li Exp $
+
+ 20 Dec 2009; Alex Legler <a3li@gentoo.org> -rails-2.2.3.ebuild,
+ -rails-2.3.4.ebuild:
+ Removing vulnerable versions
19 Dec 2009; Jeroen Roovers <jer@gentoo.org> rails-2.2.3-r1.ebuild,
rails-2.3.5.ebuild:
diff --git a/dev-ruby/rails/rails-2.2.3.ebuild b/dev-ruby/rails/rails-2.2.3.ebuild
deleted file mode 100644
index 4da97da99b90..000000000000
--- a/dev-ruby/rails/rails-2.2.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.2.3.ebuild,v 1.6 2009/10/18 17:24:48 nixnut Exp $
-
-inherit ruby gems
-USE_RUBY="ruby18"
-
-DESCRIPTION="ruby on rails is a web-application and persistance framework"
-HOMEPAGE="http://www.rubyonrails.org"
-
-LICENSE="MIT"
-SLOT="2.2"
-KEYWORDS="amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-
-IUSE="fastcgi"
-DEPEND=">=dev-lang/ruby-1.8.5
- >=app-admin/eselect-rails-0.14
- >=dev-ruby/rake-0.8.3
- ~dev-ruby/activerecord-2.2.3
- ~dev-ruby/activeresource-2.2.3
- ~dev-ruby/activesupport-2.2.3
- ~dev-ruby/actionmailer-2.2.3
- ~dev-ruby/actionpack-2.2.3"
-
-RDEPEND="${DEPEND}
- fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.6 )
- >=dev-ruby/rubygems-1.3.1"
-
-src_install() {
- gems_src_install
- # Rename slotted files that may clash so that eselect can handle
- # them
- mv "${D}/usr/bin/rails" "${D}/usr/bin/rails-${PV}"
- sed -i -e "s/>= 0/${PV}/" "${D}/usr/bin/rails-${PV}"
- mv "${D}/${GEMSDIR}/bin/rails" "${D}/${GEMSDIR}/bin/rails-${PV}"
-}
-
-pkg_postinst() {
- einfo "To select between slots of rails, use:"
- einfo "\teselect rails"
-
- eselect rails update
-}
-
-pkg_postrm() {
- eselect rails update
-}
diff --git a/dev-ruby/rails/rails-2.3.4.ebuild b/dev-ruby/rails/rails-2.3.4.ebuild
deleted file mode 100644
index bd7834527669..000000000000
--- a/dev-ruby/rails/rails-2.3.4.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.4.ebuild,v 1.6 2009/09/25 18:20:04 ranger Exp $
-
-inherit ruby gems
-USE_RUBY="ruby18 ruby19"
-
-DESCRIPTION="ruby on rails is a web-application and persistance framework"
-HOMEPAGE="http://www.rubyonrails.org"
-
-LICENSE="MIT"
-SLOT="2.3"
-KEYWORDS="amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-
-IUSE="fastcgi"
-DEPEND=">=dev-lang/ruby-1.8.6
- >=app-admin/eselect-rails-0.15
- >=dev-ruby/rake-0.8.3
- ~dev-ruby/activerecord-2.3.4
- ~dev-ruby/activeresource-2.3.4
- ~dev-ruby/activesupport-2.3.4
- ~dev-ruby/actionmailer-2.3.4
- ~dev-ruby/actionpack-2.3.4"
-
-RDEPEND="${DEPEND}
- fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.6 )
- >=dev-ruby/rubygems-1.3.2"
-
-src_install() {
- gems_src_install
- # Rename slotted files that may clash so that eselect can handle
- # them
- mv "${D}/usr/bin/rails" "${D}/usr/bin/rails-${PV}"
- sed -i -e "s/>= 0/${PV}/" "${D}/usr/bin/rails-${PV}"
- mv "${D}/${GEMSDIR}/bin/rails" "${D}/${GEMSDIR}/bin/rails-${PV}"
-}
-
-pkg_postinst() {
- einfo "To select between slots of rails, use:"
- einfo "\teselect rails"
-
- eselect rails update
-}
-
-pkg_postrm() {
- eselect rails update
-}