summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-07-16 13:25:05 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-07-16 13:25:05 +0000
commitf033e7d5887ccd64cf8c0827278834690153acda (patch)
tree64eef91c211cfddb7aaddb69ba1595890f34f8bb /dev-ruby/prawn
parentVersion bump wrt #277418, thanks to Diego E. Pettenò and Corvus Corax. (diff)
downloadgentoo-2-f033e7d5887ccd64cf8c0827278834690153acda.tar.gz
gentoo-2-f033e7d5887ccd64cf8c0827278834690153acda.tar.bz2
gentoo-2-f033e7d5887ccd64cf8c0827278834690153acda.zip
Make sure to install the needed datafiles, and patch the code to find it in our correct layout.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/prawn')
-rw-r--r--dev-ruby/prawn/ChangeLog7
-rw-r--r--dev-ruby/prawn/files/prawn-0.4.1-gentoo.patch13
-rw-r--r--dev-ruby/prawn/prawn-0.4.1.ebuild11
3 files changed, 28 insertions, 3 deletions
diff --git a/dev-ruby/prawn/ChangeLog b/dev-ruby/prawn/ChangeLog
index 0f3ed5b97f40..8b747a69e651 100644
--- a/dev-ruby/prawn/ChangeLog
+++ b/dev-ruby/prawn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/prawn
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn/ChangeLog,v 1.1 2009/07/16 13:09:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn/ChangeLog,v 1.2 2009/07/16 13:25:05 flameeyes Exp $
+
+ 16 Jul 2009; Diego E. Pettenò <flameeyes@gentoo.org> prawn-0.4.1.ebuild,
+ +files/prawn-0.4.1-gentoo.patch:
+ Make sure to install the needed datafiles, and patch the code to find it
+ in our correct layout.
*prawn-0.4.1 (16 Jul 2009)
diff --git a/dev-ruby/prawn/files/prawn-0.4.1-gentoo.patch b/dev-ruby/prawn/files/prawn-0.4.1-gentoo.patch
new file mode 100644
index 000000000000..ca2d6714fad4
--- /dev/null
+++ b/dev-ruby/prawn/files/prawn-0.4.1-gentoo.patch
@@ -0,0 +1,13 @@
+Index: sandal-prawn-c5c1ddba07efa45fd4b10085ab5ca255a43269be/lib/prawn.rb
+===================================================================
+--- sandal-prawn-c5c1ddba07efa45fd4b10085ab5ca255a43269be.orig/lib/prawn.rb
++++ sandal-prawn-c5c1ddba07efa45fd4b10085ab5ca255a43269be/lib/prawn.rb
+@@ -18,7 +18,7 @@ module Prawn
+ dir = File.dirname(file)
+
+ # The base source directory for Prawn as installed on the system
+- BASEDIR = File.expand_path(File.join(dir, '..'))
++ BASEDIR = "/usr/share/prawn"
+
+ VERSION = "0.4.1"
+
diff --git a/dev-ruby/prawn/prawn-0.4.1.ebuild b/dev-ruby/prawn/prawn-0.4.1.ebuild
index 76507648510a..8a8aef8cfed6 100644
--- a/dev-ruby/prawn/prawn-0.4.1.ebuild
+++ b/dev-ruby/prawn/prawn-0.4.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn/prawn-0.4.1.ebuild,v 1.1 2009/07/16 13:09:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn/prawn-0.4.1.ebuild,v 1.2 2009/07/16 13:25:05 flameeyes Exp $
EAPI=2
GITHUB_USER=sandal
-inherit ruby
+inherit ruby eutils
DESCRIPTION="Fast, Nimble PDF Generation For Ruby"
HOMEPAGE="http://prawn.majesticseacreature.com/"
@@ -24,6 +24,7 @@ RDEPEND="dev-ruby/ttfunk"
DEPEND="doc? ( dev-ruby/rake )
test? (
dev-ruby/rake
+ dev-ruby/mocha
dev-ruby/test-spec
>=dev-ruby/pdf-reader-0.7.3
${RDEPEND}
@@ -64,10 +65,16 @@ EOF
src_install() {
cd "${WORKDIR}"/${GITHUB_USER}-${PN}-*
+ # This sucks but it has to go after test and before install.
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+
pushd lib
doruby -r * || die "install lib failed"
popd
+ insinto /usr/share/${PN}
+ doins -r data || die
+
dofakegemspec
dodoc README HACKING || die "Installing docs failed."