summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-05 11:21:40 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-05 11:21:40 +0000
commitec205acd5ffec5b1a5238998c0fa2217d1708f1e (patch)
treee30548736ac0750a831dde3a72866568dc40d22e /dev-ruby/ox
parentRemove unnecessary java-pkg_getjars line from src_prepare; fixes bug #487002,... (diff)
downloadgentoo-2-ec205acd5ffec5b1a5238998c0fa2217d1708f1e.tar.gz
gentoo-2-ec205acd5ffec5b1a5238998c0fa2217d1708f1e.tar.bz2
gentoo-2-ec205acd5ffec5b1a5238998c0fa2217d1708f1e.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/ox')
-rw-r--r--dev-ruby/ox/ChangeLog7
-rw-r--r--dev-ruby/ox/ox-2.0.9-r1.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-ruby/ox/ChangeLog b/dev-ruby/ox/ChangeLog
index 891403178294..28699e7fad6b 100644
--- a/dev-ruby/ox/ChangeLog
+++ b/dev-ruby/ox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ox
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ox/ChangeLog,v 1.2 2013/09/02 22:46:12 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ox/ChangeLog,v 1.3 2013/10/05 11:21:40 mrueg Exp $
+
+*ox-2.0.9-r1 (05 Oct 2013)
+
+ 05 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +ox-2.0.9-r1.ebuild:
+ Add ruby20 target.
*ox-2.0.9 (02 Sep 2013)
diff --git a/dev-ruby/ox/ox-2.0.9-r1.ebuild b/dev-ruby/ox/ox-2.0.9-r1.ebuild
new file mode 100644
index 000000000000..b4103a213bf7
--- /dev/null
+++ b/dev-ruby/ox/ox-2.0.9-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ox/ox-2.0.9-r1.ebuild,v 1.1 2013/10/05 11:21:40 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A fast XML parser and Object marshaller"
+HOMEPAGE="http://www.ohler.com/ox/ https://github.com/ohler55/ox"
+SRC_URI="https://github.com/ohler55/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ox extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/ox
+ cp ext/ox/ox$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/tests.rb || die
+}