summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-24 05:44:34 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-24 05:44:34 +0000
commit00f68b4228131a9b04c71607ad6993b2bce74d7c (patch)
tree9e6d7cae0f101a819761fc1150f1b59b3bba321f /dev-ruby/oauth2
parentAdd ruby21. (diff)
downloadgentoo-2-00f68b4228131a9b04c71607ad6993b2bce74d7c.tar.gz
gentoo-2-00f68b4228131a9b04c71607ad6993b2bce74d7c.tar.bz2
gentoo-2-00f68b4228131a9b04c71607ad6993b2bce74d7c.zip
Version bump. Add ruby20.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/ChangeLog7
-rw-r--r--dev-ruby/oauth2/oauth2-0.9.4.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/oauth2/ChangeLog b/dev-ruby/oauth2/ChangeLog
index eff154748e79..c99a978f8cbe 100644
--- a/dev-ruby/oauth2/ChangeLog
+++ b/dev-ruby/oauth2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/oauth2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.19 2014/01/22 06:59:40 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.20 2014/05/24 05:44:34 graaff Exp $
+
+*oauth2-0.9.4 (24 May 2014)
+
+ 24 May 2014; Hans de Graaff <graaff@gentoo.org> +oauth2-0.9.4.ebuild:
+ Version bump. Add ruby20.
*oauth2-0.9.3 (22 Jan 2014)
diff --git a/dev-ruby/oauth2/oauth2-0.9.4.ebuild b/dev-ruby/oauth2/oauth2-0.9.4.ebuild
new file mode 100644
index 000000000000..9014361a43f8
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-0.9.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.9.4.ebuild,v 1.1 2014/05/24 05:44:34 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
+HOMEPAGE="http://github.com/intridea/oauth2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/faraday-0.8
+ >=dev-ruby/jwt-0.1.8
+ >=dev-ruby/multi_json-1.0.3
+ >=dev-ruby/multi_xml-0.5
+ >=dev-ruby/rack-1.2"
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/helper.rb || die
+
+ sed -i -e '/yardstick/,/^end/ s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec spec || die
+}