summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-01-07 07:28:49 +0000
committerHans de Graaff <graaff@gentoo.org>2010-01-07 07:28:49 +0000
commitec7c00c41b776d58ac31dfcea7555a8ab3afa50e (patch)
tree932460688616e1d1686c828fa44ed78dca2479e5 /dev-ruby/gruff
parentFix broken Manifest entry for xen-sources-2.6.29-r4.ebuild. (diff)
downloadgentoo-2-ec7c00c41b776d58ac31dfcea7555a8ab3afa50e.tar.gz
gentoo-2-ec7c00c41b776d58ac31dfcea7555a8ab3afa50e.tar.bz2
gentoo-2-ec7c00c41b776d58ac31dfcea7555a8ab3afa50e.zip
Move here from ruby-ng testbed, including two patches. Add additional patch for broken spider graph label.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/gruff')
-rw-r--r--dev-ruby/gruff/ChangeLog12
-rw-r--r--dev-ruby/gruff/files/gruff-0.3.6-fix-tests.patch24
-rw-r--r--dev-ruby/gruff/files/gruff-0.3.6-sort-filenames.patch39
-rw-r--r--dev-ruby/gruff/files/gruff-0.3.6-spider.patch13
-rw-r--r--dev-ruby/gruff/gruff-0.3.6-r1.ebuild34
5 files changed, 120 insertions, 2 deletions
diff --git a/dev-ruby/gruff/ChangeLog b/dev-ruby/gruff/ChangeLog
index 444e5af9af89..d238b785e330 100644
--- a/dev-ruby/gruff/ChangeLog
+++ b/dev-ruby/gruff/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/gruff
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gruff/ChangeLog,v 1.27 2009/12/15 18:58:28 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gruff/ChangeLog,v 1.28 2010/01/07 07:28:48 graaff Exp $
+
+*gruff-0.3.6-r1 (07 Jan 2010)
+
+ 07 Jan 2010; Hans de Graaff <graaff@gentoo.org> +gruff-0.3.6-r1.ebuild,
+ +files/gruff-0.3.6-fix-tests.patch,
+ +files/gruff-0.3.6-sort-filenames.patch, +files/gruff-0.3.6-spider.patch:
+ Move here from ruby-ng testbed, including two patches. Add additional
+ patch for broken spider graph label.
15 Dec 2009; Raúl Porcel <armin76@gentoo.org> gruff-0.3.6.ebuild:
ia64 stable wrt #295801
diff --git a/dev-ruby/gruff/files/gruff-0.3.6-fix-tests.patch b/dev-ruby/gruff/files/gruff-0.3.6-fix-tests.patch
new file mode 100644
index 000000000000..9e90c2e9ba5a
--- /dev/null
+++ b/dev-ruby/gruff/files/gruff-0.3.6-fix-tests.patch
@@ -0,0 +1,24 @@
+From 83c3ce9b01311dd18da0eff717d46734d5e96b83 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Diego=20Elio=20'Flameeyes'=20Petten=C3=B2?= <flameeyes@gmail.com>
+Date: Sat, 5 Sep 2009 21:54:24 +0200
+Subject: [PATCH 2/2] Remove a call to set label_max_decimals on Gruff::Line that doesn't exist.
+
+---
+ test/test_line.rb | 1 -
+ 1 files changed, 0 insertions(+), 1 deletions(-)
+
+diff --git a/test/test_line.rb b/test/test_line.rb
+index 4135b1e..1531931 100644
+--- a/test/test_line.rb
++++ b/test/test_line.rb
+@@ -462,7 +462,6 @@ class TestGruffLine < GruffTestCase
+ g.legend_font_size = 12
+ g.marker_font_size = 16
+ g.hide_dots = false
+- g.label_max_decimals = 1
+
+ g.write('test/output/line_jruby_error.png')
+ end
+--
+1.6.4.2
+
diff --git a/dev-ruby/gruff/files/gruff-0.3.6-sort-filenames.patch b/dev-ruby/gruff/files/gruff-0.3.6-sort-filenames.patch
new file mode 100644
index 000000000000..3ec23f16d576
--- /dev/null
+++ b/dev-ruby/gruff/files/gruff-0.3.6-sort-filenames.patch
@@ -0,0 +1,39 @@
+From 60d0bcc1de340d29c5bad3c707b49be7195e119b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Diego=20Elio=20'Flameeyes'=20Petten=C3=B2?= <flameeyes@gmail.com>
+Date: Sat, 5 Sep 2009 21:52:18 +0200
+Subject: [PATCH 1/2] Make sure the Gruff::Layer::filenames array is sorted when creating.
+
+If the array is not sorted, the rest of the class fails to work as intended
+and the tests fail:
+
+ 2) Failure:
+test_layer(TestGruffScene) [./test/test_scene.rb:54]:
+<["cloudy.png", "partly_cloudy.png", "stormy.png"]> expected but was
+<["stormy.png", "partly_cloudy.png", "cloudy.png"]>.
+
+and
+
+ 2) Failure:
+test_layer(TestGruffScene) [./test/test_scene.rb:61]:
+<"1200.png"> expected but was
+<"0600.png">.
+---
+ lib/gruff/scene.rb | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/lib/gruff/scene.rb b/lib/gruff/scene.rb
+index 47943db..ef93656 100644
+--- a/lib/gruff/scene.rb
++++ b/lib/gruff/scene.rb
+@@ -133,7 +133,7 @@ class Gruff::Layer
+ def initialize(base_dir, folder_name)
+ @base_dir = base_dir.to_s
+ @name = folder_name.to_s
+- @filenames = Dir.open(File.join(base_dir, folder_name)).entries.select { |file| file =~ /^[^.]+\.png$/ }
++ @filenames = Dir.open(File.join(base_dir, folder_name)).entries.select { |file| file =~ /^[^.]+\.png$/ }.sort
+ @selected_filename = select_default
+ end
+
+--
+1.6.4.2
+
diff --git a/dev-ruby/gruff/files/gruff-0.3.6-spider.patch b/dev-ruby/gruff/files/gruff-0.3.6-spider.patch
new file mode 100644
index 000000000000..0e7a8bbcfab8
--- /dev/null
+++ b/dev-ruby/gruff/files/gruff-0.3.6-spider.patch
@@ -0,0 +1,13 @@
+--- lib/gruff/spider.rb.orig 2007-03-08 10:22:36.000000000 +0100
++++ lib/gruff/spider.rb 2007-03-08 10:38:50.000000000 +0100
+@@ -34,8 +34,8 @@
+ return unless @has_data
+
+ # Setup basic positioning
+- diameter = @graph_height
+- radius = @graph_height / 2.0
++ diameter = @graph_height - 50
++ radius = diameter / 2.0
+ top_x = @graph_left + (@graph_width - diameter) / 2.0
+ center_x = @graph_left + (@graph_width / 2.0)
+ center_y = @graph_top + (@graph_height / 2.0) - 25 # Move graph up a bit
diff --git a/dev-ruby/gruff/gruff-0.3.6-r1.ebuild b/dev-ruby/gruff/gruff-0.3.6-r1.ebuild
new file mode 100644
index 000000000000..9063bc40286c
--- /dev/null
+++ b/dev-ruby/gruff/gruff-0.3.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gruff/gruff-0.3.6-r1.ebuild,v 1.1 2010/01/07 07:28:48 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets rails_generators"
+
+inherit ruby-fakegem
+
+ruby_add_rdepend '>=dev-ruby/rmagick-2'
+ruby_add_bdepend test "dev-ruby/hoe virtual/ruby-test-unit"
+ruby_add_bdepend doc dev-ruby/hoe
+
+DESCRIPTION="RMagick Implementation for JRuby"
+HOMEPAGE="http://rubyforge.org/projects/gruff/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+RUBY_PATCHES=(
+ ${P}-sort-filenames.patch
+ ${P}-fix-tests.patch
+ ${P}-spider.patch
+)