summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-10-18 07:30:17 +0000
committerHans de Graaff <graaff@gentoo.org>2012-10-18 07:30:17 +0000
commitf0335cdf5ed84c1e32ebbdd735bff3e002d1c9fc (patch)
tree09708a3fd436718907e9f4846bbc57d4be3328d8 /dev-ruby/gruff/gruff-0.3.7.ebuild
parentVersion bump. (diff)
downloadgentoo-2-f0335cdf5ed84c1e32ebbdd735bff3e002d1c9fc.tar.gz
gentoo-2-f0335cdf5ed84c1e32ebbdd735bff3e002d1c9fc.tar.bz2
gentoo-2-f0335cdf5ed84c1e32ebbdd735bff3e002d1c9fc.zip
Version bump.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/gruff/gruff-0.3.7.ebuild')
-rw-r--r--dev-ruby/gruff/gruff-0.3.7.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/gruff/gruff-0.3.7.ebuild b/dev-ruby/gruff/gruff-0.3.7.ebuild
new file mode 100644
index 000000000000..95274f397e9a
--- /dev/null
+++ b/dev-ruby/gruff/gruff-0.3.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gruff/gruff-0.3.7.ebuild,v 1.1 2012/10/18 07:30:17 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets rails_generators"
+
+inherit ruby-fakegem
+
+ruby_add_rdepend '>=dev-ruby/rmagick-2'
+ruby_add_bdepend "
+ test? (
+ dev-ruby/hoe
+ )"
+
+DESCRIPTION="RMagick Implementation for JRuby"
+HOMEPAGE="http://rubyforge.org/projects/gruff/"
+#SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE=""
+
+RUBY_PATCHES=(
+ ${PN}-0.3.6-spider.patch
+)
+
+# imagemagick is an indirect dependency through rmagick. However, for
+# gruff to work properly imagemagick needs to be compiled with
+# truetype support and this cannot be expressed in the rmagick
+# dependency. Test also require imagemagick to have jpeg support.
+DEPEND="${DEPEND} test? ( media-gfx/imagemagick[jpeg,truetype] )"
+RDEPEND="${RDEPEND} media-gfx/imagemagick[truetype]"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/test_*.rb
+}