summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-08-10 11:14:47 +0000
committerTom William Payne <twp@gentoo.org>2003-08-10 11:14:47 +0000
commit412a32e9643d590a1247996d83fabdb649151eab (patch)
treee53fd44260fcc38d2b12911c92c3a698ad61829e /dev-ruby/fxruby/fxruby-1.0.25.ebuild
parentVersion bump (diff)
downloadgentoo-2-412a32e9643d590a1247996d83fabdb649151eab.tar.gz
gentoo-2-412a32e9643d590a1247996d83fabdb649151eab.tar.bz2
gentoo-2-412a32e9643d590a1247996d83fabdb649151eab.zip
Version bump
Diffstat (limited to 'dev-ruby/fxruby/fxruby-1.0.25.ebuild')
-rw-r--r--dev-ruby/fxruby/fxruby-1.0.25.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/fxruby/fxruby-1.0.25.ebuild b/dev-ruby/fxruby/fxruby-1.0.25.ebuild
new file mode 100644
index 000000000000..f427f3870f92
--- /dev/null
+++ b/dev-ruby/fxruby/fxruby-1.0.25.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.0.25.ebuild,v 1.1 2003/08/10 11:14:25 twp Exp $
+
+MY_P=FXRuby-${PV}
+DESCRIPTION="Ruby language binding to the FOX GUI toolkit"
+HOMEPAGE="http://www.fxruby.org/"
+SRC_URI="mirror://sourceforge/fxruby/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha arm hppa mips sparc x86"
+IUSE=""
+DEPEND=">=dev-lang/ruby-1.6
+ >=x11-libs/fox-1.0"
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ ruby install.rb config --prefix=/usr || die
+ ruby install.rb setup || die
+}
+
+src_install() {
+ ruby install.rb config --prefix=${D}/usr || die
+ ruby install.rb install || die
+
+ dodoc ANNOUNCE ChangeLog README*
+ cp -dr examples ${D}/usr/share/doc/${PF}
+ dohtml -r doc/*
+}