summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-30 17:23:40 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-30 17:23:40 +0000
commitd06f0eb86cf4d21f6affdeb9091ad7b3987a5845 (patch)
treec4dcf25ab249e4bd52021a456e5b37c7072a83f3 /dev-ruby/fast_gettext
parentVersion bump. (diff)
downloadgentoo-2-d06f0eb86cf4d21f6affdeb9091ad7b3987a5845.tar.gz
gentoo-2-d06f0eb86cf4d21f6affdeb9091ad7b3987a5845.tar.bz2
gentoo-2-d06f0eb86cf4d21f6affdeb9091ad7b3987a5845.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/fast_gettext')
-rw-r--r--dev-ruby/fast_gettext/ChangeLog7
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-0.5.13.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/fast_gettext/ChangeLog b/dev-ruby/fast_gettext/ChangeLog
index 7b2c2ffad0a3..eb7fd9814735 100644
--- a/dev-ruby/fast_gettext/ChangeLog
+++ b/dev-ruby/fast_gettext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fast_gettext
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.2 2011/06/17 18:05:57 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.3 2011/06/30 17:23:40 graaff Exp $
+
+*fast_gettext-0.5.13 (30 Jun 2011)
+
+ 30 Jun 2011; Hans de Graaff <graaff@gentoo.org> +fast_gettext-0.5.13.ebuild:
+ Version bump.
*fast_gettext-0.5.12 (17 Jun 2011)
diff --git a/dev-ruby/fast_gettext/fast_gettext-0.5.13.ebuild b/dev-ruby/fast_gettext/fast_gettext-0.5.13.ebuild
new file mode 100644
index 000000000000..7ce2454eb77a
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-0.5.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/fast_gettext-0.5.13.ebuild,v 1.1 2011/06/30 17:23:40 graaff Exp $
+
+EAPI="4"
+
+# jruby support requires sqlite3 support for jruby.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5 x faster, 560 x less memory, simple, clean namespace (7 vs 34) and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/activerecord )"
+
+all_ruby_prepare() {
+ rm Gemfile Gemfile.lock || die
+}