summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-12-17 10:48:57 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-12-17 10:48:57 +0000
commitd6350bb0a26914abe50acee32eb4f97273684e3c (patch)
tree37299bf24d825ab128da4144d6a7d04d8333533c /dev-ruby/daemon_controller
parentVersion bump. (diff)
downloadgentoo-2-d6350bb0a26914abe50acee32eb4f97273684e3c.tar.gz
gentoo-2-d6350bb0a26914abe50acee32eb4f97273684e3c.tar.bz2
gentoo-2-d6350bb0a26914abe50acee32eb4f97273684e3c.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/daemon_controller')
-rw-r--r--dev-ruby/daemon_controller/ChangeLog7
-rw-r--r--dev-ruby/daemon_controller/daemon_controller-1.1.8.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/daemon_controller/ChangeLog b/dev-ruby/daemon_controller/ChangeLog
index a379c29673ef..93f45fa2050e 100644
--- a/dev-ruby/daemon_controller/ChangeLog
+++ b/dev-ruby/daemon_controller/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/daemon_controller
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/ChangeLog,v 1.26 2013/11/11 16:54:35 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/ChangeLog,v 1.27 2013/12/17 10:48:57 mrueg Exp $
+
+*daemon_controller-1.1.8 (17 Dec 2013)
+
+ 17 Dec 2013; Manuel Rüger <mrueg@gentoo.org> +daemon_controller-1.1.8.ebuild:
+ Version bump.
11 Nov 2013; Manuel Rüger <mrueg@gentoo.org>
-daemon_controller-1.1.5-r1.ebuild:
diff --git a/dev-ruby/daemon_controller/daemon_controller-1.1.8.ebuild b/dev-ruby/daemon_controller/daemon_controller-1.1.8.ebuild
new file mode 100644
index 000000000000..afa7dc779566
--- /dev/null
+++ b/dev-ruby/daemon_controller/daemon_controller-1.1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/daemon_controller-1.1.8.ebuild,v 1.1 2013/12/17 10:48:57 mrueg Exp $
+
+EAPI=5
+
+# jruby → fails tests, looks like Unix sockets are bad on JRuby
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for starting and stopping specific daemons programmatically in a robust manner."
+HOMEPAGE="http://github.com/FooBarWidget/daemon_controller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # fix tests with RSpec 2
+ sed -i -e '1irequire "thread"' spec/test_helper.rb || die
+}