summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJerry Alexandratos <jerry@gentoo.org>2000-11-17 08:22:05 +0000
committerJerry Alexandratos <jerry@gentoo.org>2000-11-17 08:22:05 +0000
commite9e5400092458ce2ac5e8e8e392f09fdfc7bcde8 (patch)
tree28014ea8be64a846251a7462553db444823ad771 /dev-ruby/amstd
parentInitial import of Ruby, the OO scripting lang, into the portage tree. (diff)
downloadgentoo-2-e9e5400092458ce2ac5e8e8e392f09fdfc7bcde8.tar.gz
gentoo-2-e9e5400092458ce2ac5e8e8e392f09fdfc7bcde8.tar.bz2
gentoo-2-e9e5400092458ce2ac5e8e8e392f09fdfc7bcde8.zip
Initial import of a slew or Ruby modules. This is the base for
generating RD (similar to Perl's POD) files. Hey, we might as well start with the ability to document the code we write. 8) The modules installed are: amstd -- standard libraries for Ruby optparse -- an option parser racc -- lexical parser strscan -- fast string formatter/scanner rdtool -- RD doc formatter
Diffstat (limited to 'dev-ruby/amstd')
-rw-r--r--dev-ruby/amstd/amstd-1.9.5.ebuild25
-rw-r--r--dev-ruby/amstd/files/digest-amstd-1.9.51
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/amstd/amstd-1.9.5.ebuild b/dev-ruby/amstd/amstd-1.9.5.ebuild
new file mode 100644
index 000000000000..0a4d29a6569b
--- /dev/null
+++ b/dev-ruby/amstd/amstd-1.9.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amstd/amstd-1.9.5.ebuild,v 1.1 2000/11/17 08:22:04 jerry Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard libraries for Ruby"
+SRC_URI="http://www1.u-netsurf.ne.jp/~brew/mine/soft/${A}"
+HOMEPAGE="http://www1.u-netsurf.ne.jp/~brew/mine/en/index.html"
+
+DEPEND=">=dev-lang/ruby-1.6.1"
+
+src_compile() {
+ cd ${S}
+ try ruby setup.rb config
+ try ruby setup.rb setup
+}
+
+src_install () {
+ cd ${S}
+ try ruby setup.rb install --bin-dir=${D}/usr/bin \
+ --rb-dir=${D}/usr/lib/ruby/site_ruby/1.6 \
+ --so-dir=${D}/usr/lib/ruby/site_ruby/1.6/i686-linux-gnu
+}
diff --git a/dev-ruby/amstd/files/digest-amstd-1.9.5 b/dev-ruby/amstd/files/digest-amstd-1.9.5
new file mode 100644
index 000000000000..5e49a59828aa
--- /dev/null
+++ b/dev-ruby/amstd/files/digest-amstd-1.9.5
@@ -0,0 +1 @@
+MD5 fb4f9bba17d759b59fb6a2ac4f836dcc amstd-1.9.5.tar.gz