summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-15 19:16:19 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-15 19:16:19 +0000
commitd31fa351d1e2a792f98a26e71551123af5050535 (patch)
treee3d7b41bc4c5365d1d644614a15578eefc2f1213 /dev-ruby/amazon-ec2
parentDrop ree18. Drop ruby18-specific limitation for yard. Install awshell script ... (diff)
downloadgentoo-2-d31fa351d1e2a792f98a26e71551123af5050535.tar.gz
gentoo-2-d31fa351d1e2a792f98a26e71551123af5050535.tar.bz2
gentoo-2-d31fa351d1e2a792f98a26e71551123af5050535.zip
Add as revision bump so people that already have this installed also get the correct script in /usr/bin
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/amazon-ec2')
-rw-r--r--dev-ruby/amazon-ec2/ChangeLog8
-rw-r--r--dev-ruby/amazon-ec2/amazon-ec2-0.9.17-r1.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/amazon-ec2/ChangeLog b/dev-ruby/amazon-ec2/ChangeLog
index f34f86d8fa39..cea4d1be6d98 100644
--- a/dev-ruby/amazon-ec2/ChangeLog
+++ b/dev-ruby/amazon-ec2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/amazon-ec2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amazon-ec2/ChangeLog,v 1.13 2013/10/15 19:14:31 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amazon-ec2/ChangeLog,v 1.14 2013/10/15 19:16:19 graaff Exp $
+
+*amazon-ec2-0.9.17-r1 (15 Oct 2013)
+
+ 15 Oct 2013; Hans de Graaff <graaff@gentoo.org> +amazon-ec2-0.9.17-r1.ebuild:
+ Add as revision bump so people that already have this installed also get the
+ correct script in /usr/bin
15 Oct 2013; Hans de Graaff <graaff@gentoo.org> amazon-ec2-0.9.17.ebuild:
Drop ree18. Drop ruby18-specific limitation for yard. Install awshell script
diff --git a/dev-ruby/amazon-ec2/amazon-ec2-0.9.17-r1.ebuild b/dev-ruby/amazon-ec2/amazon-ec2-0.9.17-r1.ebuild
new file mode 100644
index 000000000000..0127f128889f
--- /dev/null
+++ b/dev-ruby/amazon-ec2/amazon-ec2-0.9.17-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amazon-ec2/amazon-ec2-0.9.17-r1.ebuild,v 1.1 2013/10/15 19:16:19 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc ChangeLog"
+
+RUBY_FAKEGEM_BINWRAP="awshell ec2sh"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for accessing the Amazon Web Services EC2 and related"
+HOMEPAGE="http://github.com/grempe/amazon-ec2"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ >=dev-ruby/test-spec-0.10.0
+ >=dev-ruby/mocha-0.9.8
+ dev-ruby/yard
+ )"
+ruby_add_rdepend '
+ >=dev-ruby/xml-simple-1.0.12
+ virtual/ruby-ssl'
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}+ruby-1.9.2.patch
+
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+}