summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-01-07 07:04:15 +0000
committerHans de Graaff <graaff@gentoo.org>2015-01-07 07:04:15 +0000
commit905ce4eb07366abb3b872761d0b4b3b69b3ef181 (patch)
tree66377f5304319a29a9c6ae27f14b843d8689a841 /dev-ruby/activemodel
parentVersion bumps. (diff)
downloadgentoo-2-905ce4eb07366abb3b872761d0b4b3b69b3ef181.tar.gz
gentoo-2-905ce4eb07366abb3b872761d0b4b3b69b3ef181.tar.bz2
gentoo-2-905ce4eb07366abb3b872761d0b4b3b69b3ef181.zip
Version bumps.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activemodel')
-rw-r--r--dev-ruby/activemodel/ChangeLog9
-rw-r--r--dev-ruby/activemodel/activemodel-4.0.13.ebuild49
-rw-r--r--dev-ruby/activemodel/activemodel-4.1.9.ebuild45
3 files changed, 102 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 6803f12388c0..8dba631ac4d1 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.99 2015/01/01 11:00:14 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.100 2015/01/07 07:04:15 graaff Exp $
+
+*activemodel-4.1.9 (07 Jan 2015)
+*activemodel-4.0.13 (07 Jan 2015)
+
+ 07 Jan 2015; Hans de Graaff <graaff@gentoo.org> +activemodel-4.0.13.ebuild,
+ +activemodel-4.1.9.ebuild:
+ Version bumps.
01 Jan 2015; Agostino Sarubbo <ago@gentoo.org> activemodel-4.2.0.ebuild:
Stable for ~ppc64, wrt bug #534186
diff --git a/dev-ruby/activemodel/activemodel-4.0.13.ebuild b/dev-ruby/activemodel/activemodel-4.0.13.ebuild
new file mode 100644
index 000000000000..271fb38ce78c
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-4.0.13.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-4.0.13.ebuild,v 1.1 2015/01/07 07:04:15 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1.0:3.1
+ >=dev-ruby/bcrypt-ruby-3.1.7"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bundler
+ >=dev-ruby/railties-4.0.0
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.13.0:0.13
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\)/d" ../Gemfile || die
+ sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
+
+ # Fix bcrypt dependency since bcrypt uses semantic versioning.
+ sed -i -e '/bcrypt-ruby/ s/3.0.0/3.0/' lib/active_model/secure_password.rb || die
+}
diff --git a/dev-ruby/activemodel/activemodel-4.1.9.ebuild b/dev-ruby/activemodel/activemodel-4.1.9.ebuild
new file mode 100644
index 000000000000..b0e1f58b1bcb
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-4.1.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-4.1.9.ebuild,v 1.1 2015/01/07 07:04:15 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1.0:3.1
+"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/railties-4.0.0
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.14.0:0.14
+ >=dev-ruby/bcrypt-ruby-3.1.7
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|uglifier\|minitest\)/ s:^:#:" ../Gemfile || die
+}