summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-11-17 20:17:36 +0000
committerHans de Graaff <graaff@gentoo.org>2014-11-17 20:17:36 +0000
commit50418d07e3aabdd6f62365dbc18db99d9df4dd47 (patch)
tree16cc1dc1f60df0c721cc178806c347f363ec2ae9 /dev-ruby/activemodel
parentebuild maintenance (diff)
downloadgentoo-2-50418d07e3aabdd6f62365dbc18db99d9df4dd47.tar.gz
gentoo-2-50418d07e3aabdd6f62365dbc18db99d9df4dd47.tar.bz2
gentoo-2-50418d07e3aabdd6f62365dbc18db99d9df4dd47.zip
Version bump for security bug 529635.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activemodel')
-rw-r--r--dev-ruby/activemodel/ChangeLog10
-rw-r--r--dev-ruby/activemodel/activemodel-3.2.21.ebuild45
-rw-r--r--dev-ruby/activemodel/activemodel-4.0.12.ebuild49
-rw-r--r--dev-ruby/activemodel/activemodel-4.1.8.ebuild44
4 files changed, 147 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 53fda699e7ed..b04d503358e4 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.94 2014/11/07 10:15:27 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.95 2014/11/17 20:17:36 graaff Exp $
+
+*activemodel-4.1.8 (17 Nov 2014)
+*activemodel-4.0.12 (17 Nov 2014)
+*activemodel-3.2.21 (17 Nov 2014)
+
+ 17 Nov 2014; Hans de Graaff <graaff@gentoo.org> +activemodel-3.2.21.ebuild,
+ +activemodel-4.0.12.ebuild, +activemodel-4.1.8.ebuild:
+ Version bump for security bug 529635.
07 Nov 2014; Hans de Graaff <graaff@gentoo.org> -activemodel-3.2.19.ebuild,
-activemodel-4.0.9.ebuild, -activemodel-4.0.10.ebuild,
diff --git a/dev-ruby/activemodel/activemodel-3.2.21.ebuild b/dev-ruby/activemodel/activemodel-3.2.21.ebuild
new file mode 100644
index 000000000000..bc59d6589469
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.2.21.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.2.21.ebuild,v 1.1 2014/11/17 20:17:36 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource"
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.0.0:3
+ >=dev-ruby/bcrypt-ruby-3.0.0"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.13.0:0.13
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+
+ # Fix bcrypt dependency since bcrypt uses semantic versioning.
+ sed -i -e '/bcrypt-ruby/ s/3.0.0/3.0/' lib/active_model/secure_password.rb || die
+}
diff --git a/dev-ruby/activemodel/activemodel-4.0.12.ebuild b/dev-ruby/activemodel/activemodel-4.0.12.ebuild
new file mode 100644
index 000000000000..7fa49915012e
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-4.0.12.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-4.0.12.ebuild,v 1.1 2014/11/17 20:17:36 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource"
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1.0:3.1
+ >=dev-ruby/bcrypt-ruby-3.1.7"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bundler
+ >=dev-ruby/railties-4.0.0
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.13.0:0.13
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\)/d" ../Gemfile || die
+ sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
+
+ # Fix bcrypt dependency since bcrypt uses semantic versioning.
+ sed -i -e '/bcrypt-ruby/ s/3.0.0/3.0/' lib/active_model/secure_password.rb || die
+}
diff --git a/dev-ruby/activemodel/activemodel-4.1.8.ebuild b/dev-ruby/activemodel/activemodel-4.1.8.ebuild
new file mode 100644
index 000000000000..c3a1450b83ef
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-4.1.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-4.1.8.ebuild,v 1.1 2014/11/17 20:17:36 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource"
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1.0:3.1
+"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/railties-4.0.0
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.14.0:0.14
+ >=dev-ruby/bcrypt-ruby-3.1.7
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}