summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-08-11 01:43:36 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-08-11 01:43:36 +0000
commitfc7938f8ba39d24ffc54fbc85fa3a59298a82aee (patch)
tree22b02a0a112b9b1ee175cfc07326750750713bc8 /dev-python
parentold (diff)
downloadgentoo-2-fc7938f8ba39d24ffc54fbc85fa3a59298a82aee.tar.gz
gentoo-2-fc7938f8ba39d24ffc54fbc85fa3a59298a82aee.tar.bz2
gentoo-2-fc7938f8ba39d24ffc54fbc85fa3a59298a82aee.zip
updateing python-glanceclient to 0.10.0 for bug 478836
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-glanceclient/ChangeLog9
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-0.10.0.ebuild (renamed from dev-python/python-glanceclient/python-glanceclient-0.8.0.ebuild)14
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-0.7.0.ebuild36
3 files changed, 17 insertions, 42 deletions
diff --git a/dev-python/python-glanceclient/ChangeLog b/dev-python/python-glanceclient/ChangeLog
index c6a0ffdaf0a8..68e5cdb2937e 100644
--- a/dev-python/python-glanceclient/ChangeLog
+++ b/dev-python/python-glanceclient/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-glanceclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/ChangeLog,v 1.5 2013/03/11 03:02:22 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/ChangeLog,v 1.6 2013/08/11 01:43:36 prometheanfire Exp $
+
+*python-glanceclient-0.10.0 (11 Aug 2013)
+
+ 11 Aug 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +python-glanceclient-0.10.0.ebuild, -python-glanceclient-0.7.0.ebuild,
+ -python-glanceclient-0.8.0.ebuild:
+ updateing python-glanceclient to 0.10.0 for bug 478836
*python-glanceclient-0.8.0 (11 Mar 2013)
diff --git a/dev-python/python-glanceclient/python-glanceclient-0.8.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-0.10.0.ebuild
index 951d698711b8..f5a3a5ea6b0f 100644
--- a/dev-python/python-glanceclient/python-glanceclient-0.8.0.ebuild
+++ b/dev-python/python-glanceclient/python-glanceclient-0.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/python-glanceclient-0.8.0.ebuild,v 1.1 2013/03/11 03:02:22 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/python-glanceclient-0.10.0.ebuild,v 1.1 2013/08/11 01:43:36 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -28,11 +28,15 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
# >=dev-python/testrepository-0.0.13 #not packaged
# >=dev-python/testtools-0.9.22 )"
RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
- >=dev-python/python-keystoneclient-0.1.2[${PYTHON_USEDEP}]
+ >=dev-python/d2to1-0.2.10[${PYTHON_USEDEP}]
+ <dev-python/d2to1-0.3[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5[${PYTHON_USEDEP}]
+ <dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.2.1[${PYTHON_USEDEP}]
<dev-python/python-keystoneclient-1[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.6
- <dev-python/prettytable-0.7
- dev-python/pyopenssl
+ >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
>=dev-python/warlock-0.7.0[${PYTHON_USEDEP}]
<dev-python/warlock-2[${PYTHON_USEDEP}]"
diff --git a/dev-python/python-glanceclient/python-glanceclient-0.7.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-0.7.0.ebuild
deleted file mode 100644
index 716fad10cb2f..000000000000
--- a/dev-python/python-glanceclient/python-glanceclient-0.7.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/python-glanceclient-0.7.0.ebuild,v 1.5 2013/02/02 01:17:33 mr_bones_ Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="A client for the OpenStack Glance API"
-HOMEPAGE="https://github.com/openstack/python-glanceclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-#IUSE="test"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-# test? ( dev-python/mox
-# dev-python/nose
-# dev-python/nosehtmloutput
-# dev-python/openstack-nose-plugin
-# dev-python/nose-exclude
-# =dev-python/pep8-1.3.3
-# >=dev-python/sphinx-1.1.2 )"
-RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
- dev-python/python-keystoneclient[${PYTHON_USEDEP}]
- <=dev-python/prettytable-0.7
- dev-python/pyopenssl
- dev-python/warlock[${PYTHON_USEDEP}]"
-
-#python_test() {
-# "${PYTHON}" setup.py nosetests || die
-#}