summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-10-14 13:02:39 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-10-14 13:02:39 +0000
commitf9521edbef6cd5f5f37e590a84dc5ca31bd4312e (patch)
tree4b1ec680da76a68ae040290ea37cbe0e1347c294 /dev-python
parentnew version of mixxx (diff)
downloadgentoo-2-f9521edbef6cd5f5f37e590a84dc5ca31bd4312e.tar.gz
gentoo-2-f9521edbef6cd5f5f37e590a84dc5ca31bd4312e.tar.bz2
gentoo-2-f9521edbef6cd5f5f37e590a84dc5ca31bd4312e.zip
new version, other ones are ancient. Masked because of freeze.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twisted/ChangeLog7
-rw-r--r--dev-python/twisted/files/digest-twisted-0.99.41
-rw-r--r--dev-python/twisted/twisted-0.99.4.ebuild32
3 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index a5eb07ce643e..8e58854b39b0 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.3 2002/08/02 02:40:51 jnelson Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.4 2002/10/14 13:02:39 verwilst Exp $
+
+*twisted-0.99.4 (14 Okt 2002) Bart Verwilst <verwilst@gentoo.org>
+
+ Long overdue new version. Masked for testing (~x86) because of the freeze.
+
*twisted-0.19.0 (1 Aug 2002)
1 Aug 2002; Jon Nelson <jnelson@gentoo.org> twisted-0.18.0.ebuild twisted-0.19.0.ebuild :
diff --git a/dev-python/twisted/files/digest-twisted-0.99.4 b/dev-python/twisted/files/digest-twisted-0.99.4
new file mode 100644
index 000000000000..5ed2c23969fd
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-0.99.4
@@ -0,0 +1 @@
+MD5 d6b2e3fba94a2c9904204568d6bdc8d1 Twisted-0.99.4.tar.bz2 1400472
diff --git a/dev-python/twisted/twisted-0.99.4.ebuild b/dev-python/twisted/twisted-0.99.4.ebuild
new file mode 100644
index 000000000000..50cbbfeb6e58
--- /dev/null
+++ b/dev-python/twisted/twisted-0.99.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-0.99.4.ebuild,v 1.1 2002/10/14 13:02:39 verwilst Exp $
+
+S=${WORKDIR}/Twisted-${PV}
+DESCRIPTION="Twisted is a framework, written in Python, for writing networked applications."
+SRC_URI="http://twisted.sourceforge.net/Twisted-${PV}.tar.bz2"
+HOMEPAGE="http://www.twistedmatrix.com/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+DEPEND="virtual/python"
+RDEPEND="$DEPEND"
+KEYWORDS="~x86"
+
+inherit distutils
+
+src_install() {
+
+ distutils_src_install
+
+ # next few lines will install docs: 9.4 megs!
+ dodir /usr/share/doc/${PF}
+ # of course it's documentation!
+ doman doc/man/*
+ rm -rf doc/man # don't dupe the man pages
+ cd doc
+ cp -r . ${D}/usr/share/doc/${PF}
+ cd ../
+ # should be taken care of by the distutils install
+ # dodoc README TODO CREDITS
+
+}