summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-06-03 19:12:10 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-06-03 19:12:10 +0000
commitd874cb0423d03a81b343314b69e61d8043b69811 (patch)
tree28ed2f65f58cfef5926cd93ccc57666d2525640c /dev-python
parentFix backtrace that happens when trying to use the leoslyrics plugin (bug 316397) (diff)
downloadgentoo-2-d874cb0423d03a81b343314b69e61d8043b69811.tar.gz
gentoo-2-d874cb0423d03a81b343314b69e61d8043b69811.tar.bz2
gentoo-2-d874cb0423d03a81b343314b69e61d8043b69811.zip
Version bump. Also forced -DNDEBUG to fix doc generation (bug #322347)
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/matplotlib/ChangeLog9
-rw-r--r--dev-python/matplotlib/matplotlib-0.99.1.1-r1.ebuild14
-rw-r--r--dev-python/matplotlib/matplotlib-0.99.3.ebuild (renamed from dev-python/matplotlib/matplotlib-0.99.1.1-r2.ebuild)25
3 files changed, 20 insertions, 28 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index 1f5555822dac..33c58c870140 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.88 2010/05/31 20:38:42 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.89 2010/06/03 19:12:09 bicatali Exp $
+
+*matplotlib-0.99.3 (03 Jun 2010)
+
+ 03 Jun 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ matplotlib-0.99.1.1-r1.ebuild, -matplotlib-0.99.1.1-r2.ebuild,
+ +matplotlib-0.99.3.ebuild:
+ Version bump. Also forced -DNDEBUG to fix doc generation (bug #322347)
31 May 2010; Sébastien Fabbro <bicatali@gentoo.org>
files/matplotlib-0.99.1.1-libpng14.patch:
diff --git a/dev-python/matplotlib/matplotlib-0.99.1.1-r1.ebuild b/dev-python/matplotlib/matplotlib-0.99.1.1-r1.ebuild
index 99aed28eec8c..4da07a739a61 100644
--- a/dev-python/matplotlib/matplotlib-0.99.1.1-r1.ebuild
+++ b/dev-python/matplotlib/matplotlib-0.99.1.1-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.99.1.1-r1.ebuild,v 1.8 2010/05/30 16:32:31 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.99.1.1-r1.ebuild,v 1.9 2010/06/03 19:12:09 bicatali Exp $
EAPI="2"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
WX_GTK_VER="2.8"
-inherit eutils distutils wxwidgets
+inherit eutils distutils wxwidgets flag-o-matic
PDOC="users_guide_${PV}"
@@ -140,7 +140,7 @@ src_prepare() {
src_compile() {
unset DISPLAY # bug #278524
-
+ append-flags -DNDEBUG # bug #322347
distutils_src_compile_pre_hook() {
ln -fs "${EPREFIX}/usr/share/python$(python_get_version)/CXX" .
}
@@ -149,14 +149,10 @@ src_compile() {
if use doc; then
cd "${S}/doc"
export VARTEXFONTS="${T}"/fonts
- # no die function here: broken compilation at the end, do it twice,
- # result ok.
- MATPLOTLIBDATA="${S}/lib/matplotlib/mpl-data" \
- PYTHONPATH=$(ls -d "${S}"/build-$(PYTHON -f --ABI)/lib*) \
- "$(PYTHON -f)" make.py html
MATPLOTLIBDATA="${S}/lib/matplotlib/mpl-data" \
PYTHONPATH=$(ls -d "${S}"/build-$(PYTHON -f --ABI)/lib*) \
- "$(PYTHON -f)" make.py
+ "$(PYTHON -f)" make.py all
+ [[ -e build/latex/Matplotlib.pdf ]] || die "doc generation failed"
fi
}
diff --git a/dev-python/matplotlib/matplotlib-0.99.1.1-r2.ebuild b/dev-python/matplotlib/matplotlib-0.99.3.ebuild
index 0b3d5331e3c9..aa94af03b23f 100644
--- a/dev-python/matplotlib/matplotlib-0.99.1.1-r2.ebuild
+++ b/dev-python/matplotlib/matplotlib-0.99.3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.99.1.1-r2.ebuild,v 1.1 2010/05/31 20:23:16 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.99.3.ebuild,v 1.1 2010/06/03 19:12:10 bicatali Exp $
EAPI="2"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
WX_GTK_VER="2.8"
-inherit eutils distutils wxwidgets
+inherit eutils distutils wxwidgets flag-o-matic
PDOC="users_guide_${PV}"
@@ -79,20 +79,12 @@ use_setup() {
src_prepare() {
# avoid to launch xv while building examples docs
epatch "${FILESDIR}"/${PN}-0.98.5.2-no-xv.patch
-
- # removes hardcoded lib paths, should not break non-Prefix, more
- # likely to fix it in case of multilib
- epatch "${FILESDIR}"/${P}-prefix.patch
- epatch "${FILESDIR}"/${PN}-0.99.0-freebsd7+.patch
-
- # support libpng-1.4 (from upstream svn)
- epatch "${FILESDIR}"/${P}-libpng14.patch
# allow better small docs (from upstream svn)
- epatch "${FILESDIR}"/${P}-docs.patch
+ epatch "${FILESDIR}"/${PN}-0.99.1.1-docs.patch
# allow compatibility with pygtk-2.12 tooltop (from upstream svn)
- epatch "${FILESDIR}"/${P}-gtk-tooltip.patch
+ epatch "${FILESDIR}"/${PN}-0.99.1.1-gtk-tooltip.patch
# some font stuff (from upstream svn)
- epatch "${FILESDIR}"/${P}-eintr.patch
+ epatch "${FILESDIR}"/${PN}-0.99.1.1-eintr.patch
# create setup.cfg (see setup.cfg.template for any changes)
cat > setup.cfg <<-EOF
@@ -143,7 +135,7 @@ src_prepare() {
src_compile() {
unset DISPLAY # bug #278524
-
+ append-flags -DNDEBUG # bug #322347
distutils_src_compile_pre_hook() {
ln -fs "${EPREFIX}/usr/share/python$(python_get_version)/CXX" .
}
@@ -155,10 +147,7 @@ src_compile() {
MATPLOTLIBDATA="${S}/lib/matplotlib/mpl-data" \
PYTHONPATH=$(ls -d "${S}"/build-$(PYTHON -f --ABI)/lib*) \
"$(PYTHON -f)" make.py --small all
- MATPLOTLIBDATA="${S}/lib/matplotlib/mpl-data" \
- PYTHONPATH=$(ls -d "${S}"/build-$(PYTHON -f --ABI)/lib*) \
- "$(PYTHON -f)" make.py --small all
- [[ -e build/latex/Matplotlib.pdf ]] && die "doc generation failed"
+ [[ -e build/latex/Matplotlib.pdf ]] || die "doc generation failed"
fi
}