summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-10-03 04:24:17 +0000
committerJoshua Brindle <method@gentoo.org>2003-10-03 04:24:17 +0000
commitc36832e132efc81a2dc00a28728aaa539062499f (patch)
tree23a686d3c1a9e7523ae5ce6f7e177418765b3c18 /dev-python
parentnew api version (diff)
downloadgentoo-2-c36832e132efc81a2dc00a28728aaa539062499f.tar.gz
gentoo-2-c36832e132efc81a2dc00a28728aaa539062499f.tar.bz2
gentoo-2-c36832e132efc81a2dc00a28728aaa539062499f.zip
new api version
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-selinux/Manifest2
-rw-r--r--dev-python/python-selinux/files/digest-python-selinux-2.51
-rw-r--r--dev-python/python-selinux/python-selinux-2.5.ebuild27
3 files changed, 29 insertions, 1 deletions
diff --git a/dev-python/python-selinux/Manifest b/dev-python/python-selinux/Manifest
index eceae52c55ed..83e873f86dba 100644
--- a/dev-python/python-selinux/Manifest
+++ b/dev-python/python-selinux/Manifest
@@ -1,5 +1,5 @@
MD5 e010d713dec1a57d7ae150ce2090cf62 python-selinux-1.2.ebuild 721
-MD5 31404f85cee33188413a1b6ac2d92ec2 python-selinux-2.5.ebuild 704
+MD5 31daace953366dfcdb73c1e41239229f python-selinux-2.5.ebuild 702
MD5 c9dba0198acbe5c4268b31ae753a465d ChangeLog 948
MD5 c998c579cfc08c6860f78304a67cfce9 metadata.xml 525
MD5 fe5e6d65ff52bce9f7de7629920c3644 files/digest-python-selinux-1.2 69
diff --git a/dev-python/python-selinux/files/digest-python-selinux-2.5 b/dev-python/python-selinux/files/digest-python-selinux-2.5
new file mode 100644
index 000000000000..611229c15374
--- /dev/null
+++ b/dev-python/python-selinux/files/digest-python-selinux-2.5
@@ -0,0 +1 @@
+MD5 2374cf1636281ee0d803b4ee7300d5bc python-selinux-2.5.tar.bz2 4733
diff --git a/dev-python/python-selinux/python-selinux-2.5.ebuild b/dev-python/python-selinux/python-selinux-2.5.ebuild
new file mode 100644
index 000000000000..d9f0946e4e0e
--- /dev/null
+++ b/dev-python/python-selinux/python-selinux-2.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.5.ebuild,v 1.1 2003/10/03 04:24:14 method Exp $
+
+DESCRIPTION="Python bindings for SELinux functions"
+HOMEPAGE="http://selinux.dev.gentoo.org/python"
+SRC_URI="http://selinux.dev.gentoo.org/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND="sys-libs/libselinux"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ cd ${S}
+ gcc -shared -o selinux.so -I /usr/include/python2.2/ selinux.c -lselinux
+}
+
+src_install() {
+ insinto /usr/lib/python2.2/site-packages
+ doins selinux.so
+}