summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-02-26 00:31:13 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-02-26 00:31:13 +0000
commit969dbe09d4aef736bcabe5f518fb04c5731afd45 (patch)
treec0b53a5672455cfc0257648ec83c38c259ae0d46 /dev-python
parentOops, install both binaries and headerfiles. (Manifest recommit) (diff)
downloadgentoo-2-969dbe09d4aef736bcabe5f518fb04c5731afd45.tar.gz
gentoo-2-969dbe09d4aef736bcabe5f518fb04c5731afd45.tar.bz2
gentoo-2-969dbe09d4aef736bcabe5f518fb04c5731afd45.zip
Fix qt-3.3 related compile errors.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt/ChangeLog6
-rw-r--r--dev-python/PyQt/PyQt-3.10.ebuild8
-rw-r--r--dev-python/PyQt/files/PyQt-3.10-qt-3.3.patch14
3 files changed, 26 insertions, 2 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index a895ebc684a8..59b6967c1313 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.26 2004/01/18 01:06:05 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.27 2004/02/26 00:31:12 kloeri Exp $
+
+ 26 Feb 2004; <kloeri@gentoo.org> PyQt-3.10.ebuild,
+ files/PyQt-3.10-qt-3.3.patch:
+ Fix qt-3.3 related compile errors.
*PyQt-3.10 (17 Jan 2004)
diff --git a/dev-python/PyQt/PyQt-3.10.ebuild b/dev-python/PyQt/PyQt-3.10.ebuild
index 3f48658ee6d0..b45d30cea409 100644
--- a/dev-python/PyQt/PyQt-3.10.ebuild
+++ b/dev-python/PyQt/PyQt-3.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.10.ebuild,v 1.1 2004/01/18 01:06:05 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.10.ebuild,v 1.2 2004/02/26 00:31:12 kloeri Exp $
inherit distutils
@@ -26,6 +26,12 @@ DEPEND="virtual/glibc
src_compile() {
distutils_python_version
+
+ # fix qt-3.3 compile problem
+ if has_version '=x11-libs/qt-3.3*' ; then
+ epatch "${FILESDIR}/${P}-qt-3.3.patch"
+ fi
+
# standard qt sandbox problem workaround
[ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
dodir /usr/lib/python${PYVER}/site-packages /usr/include/python${PYVER} /usr/bin /usr/share/sip
diff --git a/dev-python/PyQt/files/PyQt-3.10-qt-3.3.patch b/dev-python/PyQt/files/PyQt-3.10-qt-3.3.patch
new file mode 100644
index 000000000000..3299d2daeede
--- /dev/null
+++ b/dev-python/PyQt/files/PyQt-3.10-qt-3.3.patch
@@ -0,0 +1,14 @@
+--- PyQt-x11-gpl-3.10/sip/qttable/qtable.sip~ 2004-02-25 23:13:59.054964424 +0100
++++ PyQt-x11-gpl-3.10/sip/qttable/qtable.sip 2004-02-25 23:14:30.527179920 +0100
+@@ -168,11 +168,6 @@
+
+ virtual int rtti() const;
+ %End
+-
+-protected:
+-%If (Qt_3_2_0 -)
+- QString content() const;
+-%End
+ };
+
+