summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-06 19:13:49 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-06 19:13:49 +0000
commit8d8c7b9ac1c487102fb26b7e1c2973ed2f1414af (patch)
treeecffcfbd1a2328967770485984fcb28a41f679b1 /dev-python
parentVersion bump, how part of the H.323 app suite. Fix license, bug #426132. (diff)
downloadgentoo-2-8d8c7b9ac1c487102fb26b7e1c2973ed2f1414af.tar.gz
gentoo-2-8d8c7b9ac1c487102fb26b7e1c2973ed2f1414af.tar.bz2
gentoo-2-8d8c7b9ac1c487102fb26b7e1c2973ed2f1414af.zip
Patches added for testsuite, migrated to distutils-r1
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-recaptcha/ChangeLog9
-rw-r--r--dev-python/django-recaptcha/django-recaptcha-0.0.6-r1.ebuild32
-rw-r--r--dev-python/django-recaptcha/django-recaptcha-0.0.6.ebuild3
-rw-r--r--dev-python/django-recaptcha/files/django-recaptcha-fields.patch18
-rw-r--r--dev-python/django-recaptcha/files/django-recaptcha-settings.patch7
5 files changed, 66 insertions, 3 deletions
diff --git a/dev-python/django-recaptcha/ChangeLog b/dev-python/django-recaptcha/ChangeLog
index e922093367ec..684e0e61e134 100644
--- a/dev-python/django-recaptcha/ChangeLog
+++ b/dev-python/django-recaptcha/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/django-recaptcha
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-recaptcha/ChangeLog,v 1.4 2013/02/22 08:53:16 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-recaptcha/ChangeLog,v 1.5 2013/03/06 19:13:49 idella4 Exp $
+
+*django-recaptcha-0.0.6-r1 (06 Mar 2013)
+
+ 06 Mar 2013; Ian Delaney <idella4@gentoo.org>
+ +django-recaptcha-0.0.6-r1.ebuild, +files/django-recaptcha-fields.patch,
+ +files/django-recaptcha-settings.patch, django-recaptcha-0.0.6.ebuild:
+ Patches added for testsuite, migrated to distutils-r1
*django-recaptcha-0.0.6 (22 Feb 2013)
diff --git a/dev-python/django-recaptcha/django-recaptcha-0.0.6-r1.ebuild b/dev-python/django-recaptcha/django-recaptcha-0.0.6-r1.ebuild
new file mode 100644
index 000000000000..57fad45bf7c8
--- /dev/null
+++ b/dev-python/django-recaptcha/django-recaptcha-0.0.6-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-recaptcha/django-recaptcha-0.0.6-r1.ebuild,v 1.1 2013/03/06 19:13:49 idella4 Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy{1_9,2_0} )
+inherit distutils-r1 eutils
+
+DESCRIPTION="Django recaptcha form field/widget app"
+HOMEPAGE="http://github.com/praekelt/django-recaptcha http://pypi.python.org/pypi/django-recaptcha"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ test? ( >=dev-python/django-setuptest-0.0.6 )"
+
+# set variables for testsuite
+PATCHES=( "${FILESDIR}"/${PN}-fields.patch
+ "${FILESDIR}"/${PN}-settings.patch )
+
+python_test() {
+ export DJANGO_SETTINGS_MODULE="django.conf"
+ "${PYTHON}" captcha/tests.py && einfo "tests passed with ${PYTHON}" \
+ || die "Tests failed"
+}
diff --git a/dev-python/django-recaptcha/django-recaptcha-0.0.6.ebuild b/dev-python/django-recaptcha/django-recaptcha-0.0.6.ebuild
index 89183328bdcd..96d2793bb27f 100644
--- a/dev-python/django-recaptcha/django-recaptcha-0.0.6.ebuild
+++ b/dev-python/django-recaptcha/django-recaptcha-0.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-recaptcha/django-recaptcha-0.0.6.ebuild,v 1.1 2013/02/22 08:53:16 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-recaptcha/django-recaptcha-0.0.6.ebuild,v 1.2 2013/03/06 19:13:49 idella4 Exp $
EAPI="3"
@@ -23,6 +23,5 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}
dev-python/setuptools"
-
# Test not supported, missing dependency
# test? ( >=dev-python/django-setuptest-0.0.6 )
diff --git a/dev-python/django-recaptcha/files/django-recaptcha-fields.patch b/dev-python/django-recaptcha/files/django-recaptcha-fields.patch
new file mode 100644
index 000000000000..c4e722245434
--- /dev/null
+++ b/dev-python/django-recaptcha/files/django-recaptcha-fields.patch
@@ -0,0 +1,18 @@
+diff -ur django-recaptcha-0.0.6.orig/captcha/fields.py django-recaptcha-0.0.6/captcha/fields.py
+--- captcha/fields.py 2013-01-31 17:05:59.000000000 +0800
++++ captcha/fields.py 2013-03-07 01:44:54.804708648 +0800
+@@ -2,13 +2,12 @@
+ import sys
+
+ from django import forms
+-from django.conf import settings
+ from django.utils.encoding import smart_unicode
+ from django.utils.translation import ugettext_lazy as _
+
+ from captcha import client
+ from captcha.widgets import ReCaptcha
+-
++from captcha import settings
+
+ class ReCaptchaField(forms.CharField):
+ default_error_messages = {
diff --git a/dev-python/django-recaptcha/files/django-recaptcha-settings.patch b/dev-python/django-recaptcha/files/django-recaptcha-settings.patch
new file mode 100644
index 000000000000..8cc2f979a5bc
--- /dev/null
+++ b/dev-python/django-recaptcha/files/django-recaptcha-settings.patch
@@ -0,0 +1,7 @@
+--- /dev/null 2013-03-05 00:07:00.881999836 +0800
++++ captcha/settings.py 2013-03-07 02:27:52.302580399 +0800
+@@ -0,0 +1,3 @@
++RECAPTCHA_PUBLIC_KEY='76wtgdfsjhsydt7r5FFGFhgsdfytd656sad75fgh'
++RECAPTCHA_PRIVATE_KEY='98dfg6df7g56df6gdfgdfg65JHJH656565GFGFGs'
++RECAPTCHA_USE_SSL='True'
+