summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-11-05 05:32:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-11-05 05:32:30 +0000
commit7096d6df4b80949f73149e8c2bb01b9014bdb7dd (patch)
tree634ca6c3e49d4e50de455afb5614d6e35e8df504 /dev-python
parentversion bump (diff)
downloadgentoo-2-7096d6df4b80949f73149e8c2bb01b9014bdb7dd.tar.gz
gentoo-2-7096d6df4b80949f73149e8c2bb01b9014bdb7dd.tar.bz2
gentoo-2-7096d6df4b80949f73149e8c2bb01b9014bdb7dd.zip
Bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-ptrace/ChangeLog7
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.8.1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/python-ptrace/ChangeLog b/dev-python/python-ptrace/ChangeLog
index ea8c67c61505..6cecc0eb9648 100644
--- a/dev-python/python-ptrace/ChangeLog
+++ b/dev-python/python-ptrace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-ptrace
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.15 2014/10/17 04:15:24 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.16 2014/11/05 05:32:30 patrick Exp $
+
+*python-ptrace-0.8.1 (05 Nov 2014)
+
+ 05 Nov 2014; Patrick Lauer <patrick@gentoo.org> +python-ptrace-0.8.1.ebuild:
+ Bump
*python-ptrace-0.8 (17 Oct 2014)
diff --git a/dev-python/python-ptrace/python-ptrace-0.8.1.ebuild b/dev-python/python-ptrace/python-ptrace-0.8.1.ebuild
new file mode 100644
index 000000000000..339ffcb212f3
--- /dev/null
+++ b/dev-python/python-ptrace/python-ptrace-0.8.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.8.1.ebuild,v 1.1 2014/11/05 05:32:30 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)"
+HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ http://pypi.python.org/pypi/python-ptrace"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND="dev-libs/distorm64"
+# Req'd for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ echo "${EPYTHON}"
+ if python_is_python3; then
+ 2to3 -w ptrace
+ fi
+ "${PYTHON}" test_doc.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ # doc folder missing key files to effect a proper doc build
+ use doc && local DOCS=( README doc/* )
+ distutils-r1_python_install_all
+}