summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2013-12-25 01:19:24 +0000
committerDavide Pesavento <pesa@gentoo.org>2013-12-25 01:19:24 +0000
commit5ed18d4ae2331ce6a54598e85efa9fc9fdfcb20b (patch)
treebef36523efd70511c1dd38ddba231a59d4c75e1e /dev-python
parentversion bump (diff)
downloadgentoo-2-5ed18d4ae2331ce6a54598e85efa9fc9fdfcb20b.tar.gz
gentoo-2-5ed18d4ae2331ce6a54598e85efa9fc9fdfcb20b.tar.bz2
gentoo-2-5ed18d4ae2331ce6a54598e85efa9fc9fdfcb20b.zip
Add python 3.3 support wrt bug 488910.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 17A85C72)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/shiboken/ChangeLog8
-rw-r--r--dev-python/shiboken/shiboken-1.2.1-r1.ebuild (renamed from dev-python/shiboken/shiboken-1.2.0.ebuild)7
-rw-r--r--dev-python/shiboken/shiboken-1.2.1.ebuild87
3 files changed, 11 insertions, 91 deletions
diff --git a/dev-python/shiboken/ChangeLog b/dev-python/shiboken/ChangeLog
index 0f1fa8b5c8fb..216ede50e6b6 100644
--- a/dev-python/shiboken/ChangeLog
+++ b/dev-python/shiboken/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/shiboken
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.47 2013/11/14 00:27:21 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.48 2013/12/25 01:19:24 pesa Exp $
+
+*shiboken-1.2.1-r1 (25 Dec 2013)
+
+ 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> +shiboken-1.2.1-r1.ebuild,
+ -shiboken-1.2.0.ebuild, -shiboken-1.2.1.ebuild:
+ Add python 3.3 support wrt bug 488910.
*shiboken-1.2.1 (14 Nov 2013)
diff --git a/dev-python/shiboken/shiboken-1.2.0.ebuild b/dev-python/shiboken/shiboken-1.2.1-r1.ebuild
index 71ea94c68c1e..986f5a07c98c 100644
--- a/dev-python/shiboken/shiboken-1.2.0.ebuild
+++ b/dev-python/shiboken/shiboken-1.2.1-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.2.0.ebuild,v 1.1 2013/08/15 09:45:01 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.2.1-r1.ebuild,v 1.1 2013/12/25 01:19:24 pesa Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
inherit multilib cmake-utils python-r1
@@ -51,15 +51,16 @@ src_prepare() {
src_configure() {
configuration() {
local mycmakeargs=(
+ $(cmake-utils_use_build test TESTS)
-DPYTHON_EXECUTABLE="${PYTHON}"
-DPYTHON_SITE_PACKAGES="$(python_get_sitedir)"
-DPYTHON_SUFFIX="-${EPYTHON}"
- $(cmake-utils_use_build test TESTS)
)
if [[ ${EPYTHON} == python3* ]]; then
mycmakeargs+=(
-DUSE_PYTHON3=ON
+ -DPYTHON3_EXECUTABLE="${PYTHON}"
-DPYTHON3_INCLUDE_DIR="$(python_get_includedir)"
-DPYTHON3_LIBRARY="$(python_get_library_path)"
)
diff --git a/dev-python/shiboken/shiboken-1.2.1.ebuild b/dev-python/shiboken/shiboken-1.2.1.ebuild
deleted file mode 100644
index 13bd395a5643..000000000000
--- a/dev-python/shiboken/shiboken-1.2.1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.2.1.ebuild,v 1.1 2013/11/14 00:27:21 pesa Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2} )
-
-inherit multilib cmake-utils python-r1
-
-DESCRIPTION="A tool for creating Python bindings for C++ libraries"
-HOMEPAGE="http://qt-project.org/wiki/PySide"
-SRC_URI="http://download.qt-project.org/official_releases/pyside/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=dev-libs/libxml2-2.6.32
- >=dev-libs/libxslt-1.1.19
- >=dev-qt/qtcore-4.7.0:4
- >=dev-qt/qtxmlpatterns-4.7.0:4
- !dev-python/apiextractor
- !dev-python/generatorrunner
-"
-DEPEND="${RDEPEND}
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-qt/qtgui-4.7.0:4
- >=dev-qt/qttest-4.7.0:4
- )"
-
-DOCS=( AUTHORS ChangeLog )
-
-src_prepare() {
- # Fix inconsistent naming of libshiboken.so and ShibokenConfig.cmake,
- # caused by the usage of a different version suffix with python >= 3.2
- sed -i -e "/get_config_var('SOABI')/d" \
- cmake/Modules/FindPython3InterpWithDebug.cmake || die
-
- if use prefix; then
- cp "${FILESDIR}"/rpath.cmake .
- sed \
- -i '1iinclude(rpath.cmake)' \
- CMakeLists.txt || die
- fi
-}
-
-src_configure() {
- configuration() {
- local mycmakeargs=(
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DPYTHON_SITE_PACKAGES="$(python_get_sitedir)"
- -DPYTHON_SUFFIX="-${EPYTHON}"
- $(cmake-utils_use_build test TESTS)
- )
-
- if [[ ${EPYTHON} == python3* ]]; then
- mycmakeargs+=(
- -DUSE_PYTHON3=ON
- -DPYTHON3_INCLUDE_DIR="$(python_get_includedir)"
- -DPYTHON3_LIBRARY="$(python_get_library_path)"
- )
- fi
-
- cmake-utils_src_configure
- }
- python_foreach_impl configuration
-}
-
-src_compile() {
- python_foreach_impl cmake-utils_src_make
-}
-
-src_test() {
- python_foreach_impl cmake-utils_src_test
-}
-
-src_install() {
- installation() {
- cmake-utils_src_install
- mv "${ED}"usr/$(get_libdir)/pkgconfig/${PN}{,-${EPYTHON}}.pc || die
- }
- python_foreach_impl installation
-}