summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-07-10 01:32:49 +0000
committerMike Gilbert <floppym@gentoo.org>2015-07-10 01:32:49 +0000
commit1bcadafa8215883bf42f72dae0f8527196d611cf (patch)
treeb1e5779531b9aceb6b7cfb3079b4e354898e01c1 /dev-python
parentVersion bump. (diff)
downloadgentoo-2-1bcadafa8215883bf42f72dae0f8527196d611cf.tar.gz
gentoo-2-1bcadafa8215883bf42f72dae0f8527196d611cf.tar.bz2
gentoo-2-1bcadafa8215883bf42f72dae0f8527196d611cf.zip
Fix conditional dep on dev-python/ipaddress.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cryptography/ChangeLog6
-rw-r--r--dev-python/cryptography/cryptography-0.9.1.ebuild43
-rw-r--r--dev-python/cryptography/cryptography-0.9.2.ebuild4
-rw-r--r--dev-python/cryptography/cryptography-0.9.ebuild43
4 files changed, 7 insertions, 89 deletions
diff --git a/dev-python/cryptography/ChangeLog b/dev-python/cryptography/ChangeLog
index d8daaa512c4e..290590ca7f2c 100644
--- a/dev-python/cryptography/ChangeLog
+++ b/dev-python/cryptography/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/cryptography
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/ChangeLog,v 1.51 2015/07/08 09:15:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/ChangeLog,v 1.52 2015/07/10 01:32:49 floppym Exp $
+
+ 10 Jul 2015; Mike Gilbert <floppym@gentoo.org> -cryptography-0.9.1.ebuild,
+ -cryptography-0.9.ebuild, cryptography-0.9.2.ebuild:
+ Fix conditional dep on dev-python/ipaddress.
*cryptography-0.9.2 (08 Jul 2015)
diff --git a/dev-python/cryptography/cryptography-0.9.1.ebuild b/dev-python/cryptography/cryptography-0.9.1.ebuild
deleted file mode 100644
index 8bb64851ca9d..000000000000
--- a/dev-python/cryptography/cryptography-0.9.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/cryptography-0.9.1.ebuild,v 1.2 2015/06/21 10:48:55 maekke Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Library providing cryptographic recipes and primitives"
-HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 BSD )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- dev-libs/openssl:0
- $(python_gen_cond_dep '>=dev-python/cffi-0.8:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/ipaddress[$(python_gen_usedep python2_7 pyp)]
- dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
- dev-python/iso8601[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
- )"
-
-DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
-
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/cryptography/cryptography-0.9.2.ebuild b/dev-python/cryptography/cryptography-0.9.2.ebuild
index 779cf0eb70b3..6eeccb51b2fc 100644
--- a/dev-python/cryptography/cryptography-0.9.2.ebuild
+++ b/dev-python/cryptography/cryptography-0.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/cryptography-0.9.2.ebuild,v 1.1 2015/07/08 09:15:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/cryptography-0.9.2.ebuild,v 1.2 2015/07/10 01:32:49 floppym Exp $
EAPI=5
@@ -22,7 +22,7 @@ RDEPEND="
$(python_gen_cond_dep '>=dev-python/cffi-0.8:=[${PYTHON_USEDEP}]' 'python*')
$(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)
dev-python/idna[${PYTHON_USEDEP}]
- dev-python/ipaddress[$(python_gen_usedep python2_7 pyp)]
+ $(python_gen_cond_dep 'dev-python/ipaddress[${PYTHON_USEDEP}]' python2_7 pypy)
dev-python/pyasn1[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
diff --git a/dev-python/cryptography/cryptography-0.9.ebuild b/dev-python/cryptography/cryptography-0.9.ebuild
deleted file mode 100644
index 32490bf7c558..000000000000
--- a/dev-python/cryptography/cryptography-0.9.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/cryptography-0.9.ebuild,v 1.4 2015/05/28 18:50:42 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Library providing cryptographic recipes and primitives"
-HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 BSD )"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- dev-libs/openssl:0
- $(python_gen_cond_dep '>=dev-python/cffi-0.8:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/ipaddress[$(python_gen_usedep python2_7 pyp)]
- dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
- dev-python/iso8601[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
- )"
-
-DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
-
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}