summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-10-08 19:13:50 +0000
committerMike Gilbert <floppym@gentoo.org>2011-10-08 19:13:50 +0000
commit0ea5f53300265bc5bb3fe229f45fe3903b5e5be4 (patch)
treeb54e70c8f2bef27fe3115d12a4de4315692ca30f /dev-python
parentpngcrush use bundled libpng 1.4, because it doesn't compile against (diff)
downloadgentoo-2-0ea5f53300265bc5bb3fe229f45fe3903b5e5be4.tar.gz
gentoo-2-0ea5f53300265bc5bb3fe229f45fe3903b5e5be4.tar.bz2
gentoo-2-0ea5f53300265bc5bb3fe229f45fe3903b5e5be4.zip
Fix compilation with py2.5; thanks to Arfrever catching this.
(Portage version: 2.2.0_alpha64/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/flask/ChangeLog5
-rw-r--r--dev-python/flask/flask-0.8.ebuild10
2 files changed, 13 insertions, 2 deletions
diff --git a/dev-python/flask/ChangeLog b/dev-python/flask/ChangeLog
index b0507f0cbe94..48e1d09eb26b 100644
--- a/dev-python/flask/ChangeLog
+++ b/dev-python/flask/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/flask
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.10 2011/10/08 17:37:12 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.11 2011/10/08 19:13:50 floppym Exp $
+
+ 08 Oct 2011; Mike Gilbert <floppym@gentoo.org> flask-0.8.ebuild:
+ Fix compilation with py2.5; thanks to Arfrever catching this.
08 Oct 2011; Mike Gilbert <floppym@gentoo.org> flask-0.7.2.ebuild,
flask-0.8.ebuild:
diff --git a/dev-python/flask/flask-0.8.ebuild b/dev-python/flask/flask-0.8.ebuild
index 8c39975fa74b..04219ce629ae 100644
--- a/dev-python/flask/flask-0.8.ebuild
+++ b/dev-python/flask/flask-0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.8.ebuild,v 1.2 2011/10/08 17:37:12 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.8.ebuild,v 1.3 2011/10/08 19:13:50 floppym Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
@@ -30,6 +30,14 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ distutils_src_prepare
+
+ # Fixed an issue with an unused module for Python 2.5 (flask.session)
+ # https://github.com/mitsuhiko/flask/commit/0dd9dc37b6618b8091c2a0f849f5f3143dc6eafc
+ sed -e "s/\(from .sessions import\).*/\1 SecureCookieSession, NullSession/" -i flask/session.py || die
+}
+
src_compile() {
distutils_src_compile