summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-01-04 01:15:59 +0000
committerMike Gilbert <floppym@gentoo.org>2013-01-04 01:15:59 +0000
commit0cb00df15913fefabc2d15b65c8a75613af92839 (patch)
treece51d9a90cfba820bc41be7937c20b46c3a77212 /dev-python/yenc
parentapp-crypt/xca: version bump wrt bug 449740. (diff)
downloadgentoo-2-0cb00df15913fefabc2d15b65c8a75613af92839.tar.gz
gentoo-2-0cb00df15913fefabc2d15b65c8a75613af92839.tar.bz2
gentoo-2-0cb00df15913fefabc2d15b65c8a75613af92839.zip
Move DISTUTILS_NO_PARALLEL_BUILD to src_test.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/yenc')
-rw-r--r--dev-python/yenc/ChangeLog5
-rw-r--r--dev-python/yenc/yenc-0.4.0-r1.ebuild11
2 files changed, 9 insertions, 7 deletions
diff --git a/dev-python/yenc/ChangeLog b/dev-python/yenc/ChangeLog
index 167f27140ee2..14ee0443d45f 100644
--- a/dev-python/yenc/ChangeLog
+++ b/dev-python/yenc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/yenc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/yenc/ChangeLog,v 1.3 2013/01/04 00:43:20 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/yenc/ChangeLog,v 1.4 2013/01/04 01:15:59 floppym Exp $
+
+ 04 Jan 2013; Mike Gilbert <floppym@gentoo.org> yenc-0.4.0-r1.ebuild:
+ Move DISTUTILS_NO_PARALLEL_BUILD to src_test.
04 Jan 2013; Mike Gilbert <floppym@gentoo.org> yenc-0.4.0-r1.ebuild:
Set DISTUTILS_NO_PARALLEL_BUILD to prevent race in tests.
diff --git a/dev-python/yenc/yenc-0.4.0-r1.ebuild b/dev-python/yenc/yenc-0.4.0-r1.ebuild
index 4c53da14b2c5..867daa095827 100644
--- a/dev-python/yenc/yenc-0.4.0-r1.ebuild
+++ b/dev-python/yenc/yenc-0.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/yenc/yenc-0.4.0-r1.ebuild,v 1.2 2013/01/04 00:43:20 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/yenc/yenc-0.4.0-r1.ebuild,v 1.3 2013/01/04 01:15:59 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -18,14 +18,13 @@ IUSE=""
# Remove forced CFLAG on setup.py
PATCHES=( "${FILESDIR}"/${PN}-remove-cflags.patch )
-# Tests use a constant temp file.
-DISTUTILS_NO_PARALLEL_BUILD=1
+DOCS=( README TODO CHANGES doc/${PN}-draft.1.3.txt )
python_test() {
"${PYTHON}" test/test.py || die "Test failed."
}
-python_install_all() {
- distutils-r1_python_install_all
- dodoc doc/${PN}-draft.1.3.txt
+src_test() {
+ # Tests use a constant temp file.
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
}