summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-02-15 19:50:57 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-02-15 19:50:57 +0000
commitdc75470d1f3274fae2420580c033849bd718388f (patch)
tree74baa1c0d329f2d998c4067b69673d6a9e3a2d04 /dev-python/wxpython
parentVersion bump. Includes now commons-beanutils-bean-collections.jar fixing bug ... (diff)
downloadgentoo-2-dc75470d1f3274fae2420580c033849bd718388f.tar.gz
gentoo-2-dc75470d1f3274fae2420580c033849bd718388f.tar.bz2
gentoo-2-dc75470d1f3274fae2420580c033849bd718388f.zip
Marking wxpython-2.8.9.1-r2 ppc for bug 254696
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/ChangeLog6
-rw-r--r--dev-python/wxpython/wxpython-2.8.8.1.ebuild122
-rw-r--r--dev-python/wxpython/wxpython-2.8.9.1.ebuild122
3 files changed, 5 insertions, 245 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index c1bd922bf8b0..090393decb9f 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for dev-python/wxpython
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.118 2009/02/15 15:20:57 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.119 2009/02/15 19:50:57 dirtyepic Exp $
15 Feb 2009; Brent Baude <ranger@gentoo.org> wxpython-2.8.9.1-r2.ebuild:
Marking wxpython-2.8.9.1-r2 ppc for bug 254696
@@ -15,6 +15,10 @@
28 Jan 2009; Brent Baude <ranger@gentoo.org> wxpython-2.8.9.1-r2.ebuild:
Marking wxpython-2.8.9.1-r2 ppc64 for bug 254696
+ 15 Feb 2009; Ryan Hill <dirtyepic@gentoo.org> -wxpython-2.8.8.1.ebuild,
+ -wxpython-2.8.9.1.ebuild:
+ Remove old.
+
24 Jan 2009; Ryan Hill <dirtyepic@gentoo.org> -wxpython-2.6.4.0.ebuild:
Remove ancient ebuild.
diff --git a/dev-python/wxpython/wxpython-2.8.8.1.ebuild b/dev-python/wxpython/wxpython-2.8.8.1.ebuild
deleted file mode 100644
index 8a80b8d3b2c9..000000000000
--- a/dev-python/wxpython/wxpython-2.8.8.1.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.8.1.ebuild,v 1.9 2008/10/27 18:52:39 jer Exp $
-
-EAPI="1"
-WX_GTK_VER="2.8"
-
-inherit alternatives eutils multilib python wxwidgets flag-o-matic
-
-# Note, we don't use distutils.eclass because it doesn't seem to play nice with
-# need-wxwidgets
-
-MY_P="${P/wxpython-/wxPython-src-}"
-DESCRIPTION="A blending of the wxWindows C++ class library with Python"
-HOMEPAGE="http://www.wxpython.org/"
-SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.bz2"
-
-LICENSE="wxWinLL-3"
-SLOT="2.8"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE="opengl"
-
-RDEPEND=">=dev-lang/python-2.1
- >=x11-libs/wxGTK-${PV}:2.8
- >=x11-libs/gtk+-2.4
- >=x11-libs/pango-1.2
- >=dev-libs/glib-2.0
- media-libs/libpng
- media-libs/jpeg
- media-libs/tiff
- opengl? ( >=dev-python/pyopengl-2.0.0.44 )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-S="${WORKDIR}/${MY_P}/wxPython/"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i "s:cflags.append('-O3'):pass:" config.py || die "sed failed"
-
- epatch "${FILESDIR}"/${PN}-2.8.8-wxversion-scripts.patch
- epatch "${FILESDIR}"/${P}-musthaveapp.patch # 2.8.8.1 only
-}
-
-src_compile() {
- local mypyconf
-
- need-wxwidgets unicode
- use opengl && check_wxuse opengl
-
- append-flags -fno-strict-aliasing
-
- mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
- use opengl \
- && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
- || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
-
- mypyconf="${mypyconf} WXPORT=gtk2 UNICODE=1"
-
- python setup.py ${mypyconf} build || die "setup.py build failed"
-}
-
-src_install() {
- local mypyconf
- python_version
- local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
-
- mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
- use opengl \
- && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
- || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
-
- mypyconf="${mypyconf} WXPORT=gtk2 UNICODE=1"
-
- python setup.py ${mypyconf} install --root="${D}" \
- --install-purelib ${site_pkgs} || die "setup.py install failed"
-
- # Collision protection.
- for file in "${D}"/usr/bin/* "${D}"/${site_pkgs}/wx{version.*,.pth}; do
- mv "${file}" "${file}-${SLOT}"
- done
-
- for dir in "${D}"/${site_pkgs}/wx-${SLOT}-gtk2-{ansi,unicode}; do
- if [[ -d ${dir} ]]; then
- cp -R "${D}"/${site_pkgs}/wxaddons/ "${dir}"
- wxaddons_copied=1
- fi
- done
-
- [[ ${wxaddons_copied} ]] && rm -rf "${D}"/${site_pkgs}/wxaddons/
-}
-
-pkg_postinst() {
- local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
-
- python_mod_optimize ${site_pkgs}
-
- alternatives_auto_makesym \
- "${site_pkgs}/wx.pth" "${site_pkgs}/wx.pth-[0-9].[0-9]"
- alternatives_auto_makesym \
- "${site_pkgs}/wxversion.py" "${site_pkgs}/wxversion.py-[0-9].[0-9]"
-
- echo
- elog "Gentoo uses the Multi-version method for SLOT'ing."
- elog "Developers see this site for instructions on using 2.6 or 2.8"
- elog "with your apps:"
- elog "http://wiki.wxpython.org/index.cgi/MultiVersionInstalls"
- echo
-}
-
-pkg_postrm() {
- python_mod_cleanup
-
- local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
-
- alternatives_auto_makesym \
- "${site_pkgs}/wx.pth" "${site_pkgs}/wx.pth-[0-9].[0-9]"
- alternatives_auto_makesym \
- "${site_pkgs}/wxversion.py" "${site_pkgs}/wxversion.py-[0-9].[0-9]"
-}
diff --git a/dev-python/wxpython/wxpython-2.8.9.1.ebuild b/dev-python/wxpython/wxpython-2.8.9.1.ebuild
deleted file mode 100644
index fca37064a808..000000000000
--- a/dev-python/wxpython/wxpython-2.8.9.1.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.9.1.ebuild,v 1.2 2008/10/18 18:35:18 dirtyepic Exp $
-
-EAPI="1"
-WX_GTK_VER="2.8"
-
-inherit alternatives eutils multilib python wxwidgets flag-o-matic
-
-# Note, we don't use distutils.eclass because it doesn't seem to play nice with
-# need-wxwidgets
-
-MY_P="${P/wxpython-/wxPython-src-}"
-DESCRIPTION="A blending of the wxWindows C++ class library with Python"
-HOMEPAGE="http://www.wxpython.org/"
-SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.bz2"
-
-LICENSE="wxWinLL-3"
-SLOT="2.8"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="cairo opengl"
-
-RDEPEND=">=dev-lang/python-2.4
- >=x11-libs/wxGTK-${PV}:2.8
- >=x11-libs/gtk+-2.4
- >=x11-libs/pango-1.2
- >=dev-libs/glib-2.0
- media-libs/libpng
- media-libs/jpeg
- media-libs/tiff
- cairo? ( dev-python/pycairo )
- opengl? ( >=dev-python/pyopengl-2.0.0.44 )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-S="${WORKDIR}/${MY_P}/wxPython/"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i "s:cflags.append('-O3'):pass:" config.py || die "sed failed"
-
- epatch "${FILESDIR}"/${PN}-2.8.8-wxversion-scripts.patch
-}
-
-src_compile() {
- local mypyconf
-
- need-wxwidgets unicode
- use opengl && check_wxuse opengl
-
- append-flags -fno-strict-aliasing
-
- mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
- use opengl \
- && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
- || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
-
- mypyconf="${mypyconf} WXPORT=gtk2 UNICODE=1"
-
- python setup.py ${mypyconf} build || die "setup.py build failed"
-}
-
-src_install() {
- local mypyconf
- python_version
- local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
-
- mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
- use opengl \
- && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
- || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
-
- mypyconf="${mypyconf} WXPORT=gtk2 UNICODE=1"
-
- python setup.py ${mypyconf} install --root="${D}" \
- --install-purelib ${site_pkgs} || die "setup.py install failed"
-
- # Collision protection.
- for file in "${D}"/usr/bin/* "${D}"/${site_pkgs}/wx{version.*,.pth}; do
- mv "${file}" "${file}-${SLOT}"
- done
-
- for dir in "${D}"/${site_pkgs}/wx-${SLOT}-gtk2-{ansi,unicode}; do
- if [[ -d ${dir} ]]; then
- cp -R "${D}"/${site_pkgs}/wxaddons/ "${dir}"
- wxaddons_copied=1
- fi
- done
-
- [[ ${wxaddons_copied} ]] && rm -rf "${D}"/${site_pkgs}/wxaddons/
-}
-
-pkg_postinst() {
- local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
-
- python_mod_optimize ${site_pkgs}
-
- alternatives_auto_makesym \
- "${site_pkgs}/wx.pth" "${site_pkgs}/wx.pth-[0-9].[0-9]"
- alternatives_auto_makesym \
- "${site_pkgs}/wxversion.py" "${site_pkgs}/wxversion.py-[0-9].[0-9]"
-
- echo
- elog "Gentoo uses the Multi-version method for SLOT'ing."
- elog "Developers see this site for instructions on using 2.6 or 2.8"
- elog "with your apps:"
- elog "http://wiki.wxpython.org/index.cgi/MultiVersionInstalls"
- echo
-}
-
-pkg_postrm() {
- python_mod_cleanup
-
- local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
-
- alternatives_auto_makesym \
- "${site_pkgs}/wx.pth" "${site_pkgs}/wx.pth-[0-9].[0-9]"
- alternatives_auto_makesym \
- "${site_pkgs}/wxversion.py" "${site_pkgs}/wxversion.py-[0-9].[0-9]"
-}