summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-09-16 08:12:12 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-09-16 08:12:12 +0000
commit7a984d198401ab13d68b7b4fb3b8b8d4dba0a29f (patch)
tree07f6167d0768b08410880fb8d74b606583d5cce4 /dev-python/webob/webob-1.1.ebuild
parentVersion bump mocker to 1.1. (diff)
downloadgentoo-2-7a984d198401ab13d68b7b4fb3b8b8d4dba0a29f.tar.gz
gentoo-2-7a984d198401ab13d68b7b4fb3b8b8d4dba0a29f.tar.bz2
gentoo-2-7a984d198401ab13d68b7b4fb3b8b8d4dba0a29f.zip
Version bump webob to 1.1.
(Portage version: 2.1.10.15/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/webob/webob-1.1.ebuild')
-rw-r--r--dev-python/webob/webob-1.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/webob/webob-1.1.ebuild b/dev-python/webob/webob-1.1.ebuild
new file mode 100644
index 000000000000..cbb70c47759e
--- /dev/null
+++ b/dev-python/webob/webob-1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.1.ebuild,v 1.1 2011/09/16 08:12:12 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+MY_PN="WebOb"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="WSGI request and response object"
+HOMEPAGE="http://pythonpaste.org/webob/ http://pypi.python.org/pypi/WebOb"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/webtest )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd build/sphinx/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}