summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-03 19:27:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-03 19:27:55 +0000
commit5b17ee192067a58817ea2b2a64fe33385ebbe060 (patch)
treed09c25bea52d9ce5d7aaeb8c9465393a69dfa4f5 /dev-python/utidylib
parentFixed: unnecessary inherit, swig dependency, documentation install, static-li... (diff)
downloadgentoo-2-5b17ee192067a58817ea2b2a64fe33385ebbe060.tar.gz
gentoo-2-5b17ee192067a58817ea2b2a64fe33385ebbe060.tar.bz2
gentoo-2-5b17ee192067a58817ea2b2a64fe33385ebbe060.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/utidylib')
-rw-r--r--dev-python/utidylib/ChangeLog6
-rw-r--r--dev-python/utidylib/utidylib-0.2-r1.ebuild32
2 files changed, 20 insertions, 18 deletions
diff --git a/dev-python/utidylib/ChangeLog b/dev-python/utidylib/ChangeLog
index 2946741a3aaa..218a05b48e36 100644
--- a/dev-python/utidylib/ChangeLog
+++ b/dev-python/utidylib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/utidylib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/utidylib/ChangeLog,v 1.9 2010/02/07 20:40:17 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/utidylib/ChangeLog,v 1.10 2010/04/03 19:27:55 arfrever Exp $
+
+ 03 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ utidylib-0.2-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
07 Feb 2010; Peter Volkov <pva@gentoo.org> utidylib-0.2-r1.ebuild:
Add inherit eutils: epatch is defined there.
diff --git a/dev-python/utidylib/utidylib-0.2-r1.ebuild b/dev-python/utidylib/utidylib-0.2-r1.ebuild
index e37a72a35dfc..71e856f86fbf 100644
--- a/dev-python/utidylib/utidylib-0.2-r1.ebuild
+++ b/dev-python/utidylib/utidylib-0.2-r1.ebuild
@@ -1,9 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/utidylib/utidylib-0.2-r1.ebuild,v 1.2 2010/02/07 20:40:17 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/utidylib/utidylib-0.2-r1.ebuild,v 1.3 2010/04/03 19:27:55 arfrever Exp $
-EAPI="2"
-inherit eutils distutils
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="trial tidy"
+
+inherit distutils eutils
MY_P="uTidylib-${PV}"
@@ -14,20 +18,20 @@ SRC_URI="mirror://berlios/${PN}/${MY_P}.zip"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="doc test"
+IUSE="doc"
-RDEPEND=">=dev-lang/python-2.3
- app-text/htmltidy
- dev-python/ctypes"
+RDEPEND="app-text/htmltidy"
DEPEND="${RDEPEND}
app-arch/unzip
- doc? ( dev-python/epydoc )
- test? ( dev-python/twisted )"
+ doc? ( dev-python/epydoc )"
+RESTRICT_PYTHON_ABIS="3.*"
-PYTHON_MODNAME="tidy"
S="${WORKDIR}/${MY_P}"
+PYTHON_MODNAME="tidy"
+
src_prepare(){
+ distutils_src_prepare
epatch "${FILESDIR}/${P}-no-docs-in-site-packages.patch"
epatch "${FILESDIR}/${P}-fix_tests.patch"
}
@@ -35,16 +39,10 @@ src_prepare(){
src_compile() {
distutils_src_compile
if use doc; then
- python gendoc.py || die "building api docs failed"
+ "$(PYTHON -f)" gendoc.py || die "Generation of documentation failed"
fi
}
-src_test() {
- einfo "${S}"
- einfo "$(ls ${S}/foo.htm)"
- PYTHONPATH="." trial tidy || die "tests failed"
-}
-
src_install() {
distutils_src_install
use doc && dohtml -r apidoc