summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2005-04-08 15:14:15 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2005-04-08 15:14:15 +0000
commit138fb02f3dfb1cda010b8558f0c1b9842b891888 (patch)
tree3b7c7cbcbe92655c7a3cce3b88951caa091996f9 /dev-python/twisted-names
parentUpdating digests (diff)
downloadgentoo-2-138fb02f3dfb1cda010b8558f0c1b9842b891888.tar.gz
gentoo-2-138fb02f3dfb1cda010b8558f0c1b9842b891888.tar.bz2
gentoo-2-138fb02f3dfb1cda010b8558f0c1b9842b891888.zip
initial release
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-python/twisted-names')
-rw-r--r--dev-python/twisted-names/ChangeLog8
-rw-r--r--dev-python/twisted-names/Manifest4
-rw-r--r--dev-python/twisted-names/files/digest-twisted-names-0.1.01
-rw-r--r--dev-python/twisted-names/metadata.xml6
-rw-r--r--dev-python/twisted-names/twisted-names-0.1.0.ebuild31
5 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/twisted-names/ChangeLog b/dev-python/twisted-names/ChangeLog
new file mode 100644
index 000000000000..a776f0091a43
--- /dev/null
+++ b/dev-python/twisted-names/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-python/twisted-names
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/ChangeLog,v 1.1 2005/04/08 15:14:15 lordvan Exp $
+
+ 08 Apr 2005; Thomas Raschbacher <lordvan@gentoo.org> twisted-names-0.1.0:
+ initial import
+ twisted-names was part of the main twisted release
+
diff --git a/dev-python/twisted-names/Manifest b/dev-python/twisted-names/Manifest
new file mode 100644
index 000000000000..8202166fa043
--- /dev/null
+++ b/dev-python/twisted-names/Manifest
@@ -0,0 +1,4 @@
+MD5 f1bc8f4bae53f5a996d7fb1f99d646ea twisted-names-0.1.0.ebuild 811
+MD5 b3fca05c5d10167c584c057e5578b278 ChangeLog 369
+MD5 19df39ef54fc4a8677998f19bb6046ac metadata.xml 218
+MD5 bce5421a13546c1574eb9fcd01093802 files/digest-twisted-names-0.1.0 70
diff --git a/dev-python/twisted-names/files/digest-twisted-names-0.1.0 b/dev-python/twisted-names/files/digest-twisted-names-0.1.0
new file mode 100644
index 000000000000..68991ebff93d
--- /dev/null
+++ b/dev-python/twisted-names/files/digest-twisted-names-0.1.0
@@ -0,0 +1 @@
+MD5 1489cb84aa4abfd371441090e5e12f0e TwistedNames-0.1.0.tar.bz2 28486
diff --git a/dev-python/twisted-names/metadata.xml b/dev-python/twisted-names/metadata.xml
new file mode 100644
index 000000000000..37d1f8e02e49
--- /dev/null
+++ b/dev-python/twisted-names/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<maintainer><email>lordvan@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/dev-python/twisted-names/twisted-names-0.1.0.ebuild b/dev-python/twisted-names/twisted-names-0.1.0.ebuild
new file mode 100644
index 000000000000..7b7b5e566660
--- /dev/null
+++ b/dev-python/twisted-names/twisted-names-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/twisted-names-0.1.0.ebuild,v 1.1 2005/04/08 15:14:15 lordvan Exp $
+
+inherit distutils
+
+# for alphas,..
+MY_PV="${PV/_alpha/a}"
+MY_PN="TwistedNames"
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="An NNTP protocol implementation with client and server(?)"
+HOMEPAGE="http://twistedmatrix.com/projects/names/"
+SRC_URI="http://tmrc.mit.edu/mirror/twisted/Names/0.1/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~alpha ~sparc"
+IUSE="doc"
+
+DEPEND=">=dev-python/twisted-2.0.0"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dodir /usr/share/doc/${P}
+ cp -r ${S}/docs ${D}/usr/share/doc/${P}/
+ fi
+}