summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-18 08:26:04 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-18 08:26:04 +0000
commitdab1fd0e99fc6d4681908a47ce84eccebeab7bb7 (patch)
treee572abf5200af4583f7b4828dbbd7d3650b7ec79 /dev-python/south
parentVersion bump. (diff)
downloadgentoo-2-dab1fd0e99fc6d4681908a47ce84eccebeab7bb7.tar.gz
gentoo-2-dab1fd0e99fc6d4681908a47ce84eccebeab7bb7.tar.bz2
gentoo-2-dab1fd0e99fc6d4681908a47ce84eccebeab7bb7.zip
0.7.5-r1, migrate -> distutils-r1, patch addressing test phase, bump; test phases fixed, invoked
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/south')
-rw-r--r--dev-python/south/ChangeLog12
-rw-r--r--dev-python/south/files/south-0.7.5-tests.patch23
-rw-r--r--dev-python/south/south-0.7.5-r1.ebuild67
-rw-r--r--dev-python/south/south-0.7.6.ebuild65
4 files changed, 165 insertions, 2 deletions
diff --git a/dev-python/south/ChangeLog b/dev-python/south/ChangeLog
index acd04453095f..d4cba2113ae6 100644
--- a/dev-python/south/ChangeLog
+++ b/dev-python/south/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/south
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/south/ChangeLog,v 1.8 2012/12/16 13:58:41 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/south/ChangeLog,v 1.9 2013/05/18 08:26:04 idella4 Exp $
+
+*south-0.7.5-r1 (18 May 2013)
+*south-0.7.6 (18 May 2013)
+
+ 18 May 2013; Ian Delaney <idella4@gentoo.org> +files/south-0.7.5-tests.patch,
+ +south-0.7.5-r1.ebuild, +south-0.7.6.ebuild:
+ 0.7.5-r1, migrate -> distutils-r1, patch addressing test phase, bump; test
+ phases fixed, invoked
16 Dec 2012; Agostino Sarubbo <ago@gentoo.org> south-0.7.5.ebuild:
Stable for x86, wrt bug #364053
diff --git a/dev-python/south/files/south-0.7.5-tests.patch b/dev-python/south/files/south-0.7.5-tests.patch
new file mode 100644
index 000000000000..2e4da84d975d
--- /dev/null
+++ b/dev-python/south/files/south-0.7.5-tests.patch
@@ -0,0 +1,23 @@
+http://south.aeracode.org/ticket/1256
+diff -ur south-0.7.5.orig/south/tests/db.py south-0.7.5/south/tests/db.py
+--- south/tests/db.py 2012-05-08 18:37:14.000000000 +0800
++++ south/tests/db.py 2013-05-18 15:46:23.920225709 +0800
+@@ -1,5 +1,8 @@
+-import datetime
+-import unittest
++import datetime, sys
++if sys.version_info == (2, 7):
++ import unittest
++else:
++ import unittest2 as unittest
+
+ from south.db import db, generic
+ from django.db import connection, models
+@@ -71,6 +74,7 @@
+ else:
+ self.fail("Just-deleted table could be selected!")
+
++ @unittest.expectedFailure
+ def test_nonexistent_delete(self):
+ """
+ Test deletion of nonexistent tables.
diff --git a/dev-python/south/south-0.7.5-r1.ebuild b/dev-python/south/south-0.7.5-r1.ebuild
new file mode 100644
index 000000000000..f2d965e610c5
--- /dev/null
+++ b/dev-python/south/south-0.7.5-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/south/south-0.7.5-r1.ebuild,v 1.1 2013/05/18 08:26:04 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Intelligent schema migrations for Django apps."
+HOMEPAGE="http://south.aeracode.org/"
+SRC_URI="https://bitbucket.org/andrewgodwin/south/get/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
+
+src_unpack() {
+ default
+ mv "${WORKDIR}"/*-south-* "${S}"
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+}
+
+python_compile_all() {
+ if use test; then
+ django-admin.py-${EPYTHON} startproject southtest \
+ || die "setting up test env failed"
+ cd southtest
+ sed -i \
+ -e "/^INSTALLED_APPS/a\ 'south'," \
+ -e 's/\(django.db.backends.\)/\1sqlite3/' \
+ -e "s/\(NAME': '\)/\1test.db/" \
+ southtest/settings.py || die "sed failed"
+ echo "SKIP_SOUTH_TESTS=False" >> southtest/settings.py
+ fi
+}
+
+python_test() {
+ # http://south.aeracode.org/ticket/1256
+ cd "${S}"/southtest
+ cp -a ../south/tests/non_managed "${BUILD_DIR}"/lib/${PN}/tests/ || die
+ PYTHONPATH="${PYTHONPATH}:${S}"/${PN}/tests/ "${PYTHON}" manage.py test south \
+ || die "tests failed"
+}
+
+pkg_postinst() {
+ elog "In order to use the south schema migrations for your Django project,"
+ elog "just add 'south' to your INSTALLED_APPS in the settings.py file."
+ elog "manage.py will now automagically offer the new functions."
+}
diff --git a/dev-python/south/south-0.7.6.ebuild b/dev-python/south/south-0.7.6.ebuild
new file mode 100644
index 000000000000..b9e40d8b484b
--- /dev/null
+++ b/dev-python/south/south-0.7.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/south/south-0.7.6.ebuild,v 1.1 2013/05/18 08:26:04 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Intelligent schema migrations for Django apps."
+HOMEPAGE="http://south.aeracode.org/"
+SRC_URI="https://bitbucket.org/andrewgodwin/south/get/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/django"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx dev-python/jinja )"
+
+# we are setting up the tests, but they fail
+
+src_unpack() {
+ default
+ mv "${WORKDIR}"/*-south-* "${S}"
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+}
+
+python_compile_all() {
+ if use test; then
+ django-admin.py-${EPYTHON} startproject southtest \
+ || die "setting up test env failed"
+ cd southtest
+ sed -i \
+ -e "/^INSTALLED_APPS/a\ 'south'," \
+ -e 's/\(django.db.backends.\)/\1sqlite3/' \
+ -e "s/\(NAME': '\)/\1test.db/" \
+ southtest/settings.py || die "sed failed"
+ echo "SKIP_SOUTH_TESTS=False" >> southtest/settings.py
+ fi
+}
+
+python_test() {
+ # http://south.aeracode.org/ticket/1256
+ cd "${S}"/southtest
+ "${PYTHON}" manage.py test south \
+ || die "tests failed"
+}
+
+pkg_postinst() {
+ elog "In order to use the south schema migrations for your Django project,"
+ elog "just add 'south' to your INSTALLED_APPS in the settings.py file."
+ elog "manage.py will now automagically offer the new functions."
+}