summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-20 01:56:00 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-20 01:56:00 +0000
commitb7021a9f990b3b0b9443f35def50faa4aa7dbe6f (patch)
tree3c05e3eb669b311dec2fc13de6efe5db3f6f5a6b /dev-python/south
parentAdd libgif.so.4.1.6. (diff)
downloadgentoo-2-b7021a9f990b3b0b9443f35def50faa4aa7dbe6f.tar.gz
gentoo-2-b7021a9f990b3b0b9443f35def50faa4aa7dbe6f.tar.bz2
gentoo-2-b7021a9f990b3b0b9443f35def50faa4aa7dbe6f.zip
bump; add py3 pypy support, fix test phase, closes Bug #513540
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/south')
-rw-r--r--dev-python/south/ChangeLog9
-rw-r--r--dev-python/south/south-0.7.2.ebuild48
-rw-r--r--dev-python/south/south-0.7.3.ebuild48
-rw-r--r--dev-python/south/south-0.7.4.ebuild49
-rw-r--r--dev-python/south/south-0.7.6.ebuild64
-rw-r--r--dev-python/south/south-0.8.4.ebuild (renamed from dev-python/south/south-0.8.1.ebuild)39
6 files changed, 24 insertions, 233 deletions
diff --git a/dev-python/south/ChangeLog b/dev-python/south/ChangeLog
index 5c3bb761befd..c0507695e47c 100644
--- a/dev-python/south/ChangeLog
+++ b/dev-python/south/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/south
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/south/ChangeLog,v 1.13 2014/03/13 15:01:21 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/south/ChangeLog,v 1.14 2014/06/20 01:56:00 idella4 Exp $
+
+*south-0.8.4 (20 Jun 2014)
+
+ 20 Jun 2014; Ian Delaney <idella4@gentoo.org> +south-0.8.4.ebuild,
+ -south-0.7.2.ebuild, -south-0.7.3.ebuild, -south-0.7.4.ebuild,
+ -south-0.7.6.ebuild, -south-0.8.1.ebuild:
+ bump; add py3 pypy support, fix test phase, closes Bug #513540
*south-0.8.1-r1 (13 Mar 2014)
diff --git a/dev-python/south/south-0.7.2.ebuild b/dev-python/south/south-0.7.2.ebuild
deleted file mode 100644
index 62bd2767041f..000000000000
--- a/dev-python/south/south-0.7.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/south/south-0.7.2.ebuild,v 1.2 2011/02/13 10:49:08 betelgeuse Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="Intelligent schema migrations for Django apps."
-HOMEPAGE="http://south.aeracode.org/"
-SRC_URI="http://www.aeracode.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="dev-python/django"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-S="${WORKDIR}/${PN}"
-
-src_compile() {
- distutils_src_compile
-
- if use doc ; then
- emake -C docs html || die "building docs failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- use doc && dohtml -r docs/_build/html/*
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- elog "In order to use the south schema migrations for your Django project,"
- elog "just add 'south' to your INSTALLED_APPS in the settings.py file."
- elog "manage.py will now automagically offer the new functions."
-}
diff --git a/dev-python/south/south-0.7.3.ebuild b/dev-python/south/south-0.7.3.ebuild
deleted file mode 100644
index 47f6b518c2db..000000000000
--- a/dev-python/south/south-0.7.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/south/south-0.7.3.ebuild,v 1.2 2011/02/13 10:49:08 betelgeuse Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="Intelligent schema migrations for Django apps."
-HOMEPAGE="http://south.aeracode.org/"
-SRC_URI="http://www.aeracode.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="dev-python/django"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-S="${WORKDIR}/${PN}"
-
-src_compile() {
- distutils_src_compile
-
- if use doc ; then
- emake -C docs html || die "building docs failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- use doc && dohtml -r docs/_build/html/*
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- elog "In order to use the south schema migrations for your Django project,"
- elog "just add 'south' to your INSTALLED_APPS in the settings.py file."
- elog "manage.py will now automagically offer the new functions."
-}
diff --git a/dev-python/south/south-0.7.4.ebuild b/dev-python/south/south-0.7.4.ebuild
deleted file mode 100644
index 8a58951a3095..000000000000
--- a/dev-python/south/south-0.7.4.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/south/south-0.7.4.ebuild,v 1.1 2012/04/19 10:00:41 patrick Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="Intelligent schema migrations for Django apps."
-HOMEPAGE="http://south.aeracode.org/"
-SRC_URI="http://www.aeracode.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="dev-python/django"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-# I should leave a very angry comment here
-S="${WORKDIR}/andrewgodwin-south-738417d7a8ab/"
-
-src_compile() {
- distutils_src_compile
-
- if use doc ; then
- emake -C docs html || die "building docs failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- use doc && dohtml -r docs/_build/html/*
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- elog "In order to use the south schema migrations for your Django project,"
- elog "just add 'south' to your INSTALLED_APPS in the settings.py file."
- elog "manage.py will now automagically offer the new functions."
-}
diff --git a/dev-python/south/south-0.7.6.ebuild b/dev-python/south/south-0.7.6.ebuild
deleted file mode 100644
index fb5093ad6883..000000000000
--- a/dev-python/south/south-0.7.6.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/south/south-0.7.6.ebuild,v 1.2 2013/08/14 11:22:53 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Intelligent schema migrations for Django apps."
-HOMEPAGE="http://south.aeracode.org/"
-SRC_URI="https://bitbucket.org/andrewgodwin/south/get/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/django"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx dev-python/jinja )"
-
-# we are setting up the tests, but they fail
-
-src_unpack() {
- default
- mv "${WORKDIR}"/*-south-* "${S}"
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-}
-
-python_compile_all() {
- if use test; then
- django-admin.py-${EPYTHON} startproject southtest \
- || die "setting up test env failed"
- cd southtest
- sed -i \
- -e "/^INSTALLED_APPS/a\ 'south'," \
- -e 's/\(django.db.backends.\)/\1sqlite3/' \
- -e "s/\(NAME': '\)/\1test.db/" \
- southtest/settings.py || die "sed failed"
- echo "SKIP_SOUTH_TESTS=False" >> southtest/settings.py
- fi
-}
-
-python_test() {
- # http://south.aeracode.org/ticket/1256
- cd "${S}"/southtest
- "${PYTHON}" manage.py test south || die "tests failed"
-}
-
-pkg_postinst() {
- elog "In order to use the south schema migrations for your Django project,"
- elog "just add 'south' to your INSTALLED_APPS in the settings.py file."
- elog "manage.py will now automagically offer the new functions."
-}
diff --git a/dev-python/south/south-0.8.1.ebuild b/dev-python/south/south-0.8.4.ebuild
index bba795d8a50f..6414dd335303 100644
--- a/dev-python/south/south-0.8.1.ebuild
+++ b/dev-python/south/south-0.8.4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/south/south-0.8.1.ebuild,v 1.2 2013/06/03 04:22:41 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/south/south-0.8.4.ebuild,v 1.1 2014/06/20 01:56:00 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit vcs-snapshot distutils-r1
@@ -20,38 +20,31 @@ IUSE="doc test"
RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx dev-python/jinja )
+ doc? (
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/django[sqlite] )"
-# we are setting up the tests, but they fail
-
python_compile_all() {
use doc && emake -C docs html
}
python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
-}
-
-python_compile() {
- distutils-r1_python_compile
- if use test; then
- cd "${BUILD_DIR}"
- django-admin.py startproject southtest || die "setting up test env failed"
- cd southtest
- sed -i \
- -e "/^INSTALLED_APPS/a\ 'south'," \
- -e 's/\(django.db.backends.\)/\1sqlite3/' \
- -e "s/\(NAME': '\)/\1test.db/" \
- southtest/settings.py || die "sed failed"
- echo "SKIP_SOUTH_TESTS=False" >> southtest/settings.py
- fi
+ distutils-r1_python_install_all
}
python_test() {
- # http://south.aeracode.org/ticket/1256
- cd "${BUILD_DIR}/southtest"
+ # http://south.aeracode.org/ticket/1439
+ cd "${BUILD_DIR}" || die
+ django-admin.py startproject southtest || die "setting up test env failed"
+
+ pushd southtest > /dev/null
+ sed -e "/^INSTALLED_APPS/a\ 'south'," \
+ -e '$a\SKIP_SOUTH_TESTS=False' \
+ -i southtest/settings.py || die "test sed failed"
"${EPYTHON}" manage.py test south || die "tests failed for ${EPYTHON}"
+ popd > /dev/null
}
pkg_postinst() {