summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-02-23 18:39:42 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-02-23 18:39:42 +0000
commitf2e45f8abca9f437a585ec70176f9a7251831ed1 (patch)
tree5c4245fdb0d61677295c21f0004feb8ded5e2a0b /dev-python/sip
parentNever build and link against old dga. (diff)
downloadgentoo-2-f2e45f8abca9f437a585ec70176f9a7251831ed1.tar.gz
gentoo-2-f2e45f8abca9f437a585ec70176f9a7251831ed1.tar.bz2
gentoo-2-f2e45f8abca9f437a585ec70176f9a7251831ed1.zip
Minor code cleanup.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/ChangeLog5
-rw-r--r--dev-python/sip/sip-4.13.2.ebuild13
2 files changed, 9 insertions, 9 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 3731ab7e5394..a450bec37c16 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.208 2012/02/23 18:04:39 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.209 2012/02/23 18:39:42 pesa Exp $
+
+ 23 Feb 2012; Davide Pesavento <pesa@gentoo.org> sip-4.13.2.ebuild:
+ Minor code cleanup.
23 Feb 2012; Davide Pesavento <pesa@gentoo.org> -sip-4.12.4.ebuild,
-sip-4.13.1.ebuild, -sip-4.13.ebuild, metadata.xml:
diff --git a/dev-python/sip/sip-4.13.2.ebuild b/dev-python/sip/sip-4.13.2.ebuild
index db1f385af146..391fa5ca7343 100644
--- a/dev-python/sip/sip-4.13.2.ebuild
+++ b/dev-python/sip/sip-4.13.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.13.2.ebuild,v 1.2 2012/02/20 10:13:40 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.13.2.ebuild,v 1.3 2012/02/23 18:39:42 pesa Exp $
EAPI="3"
PYTHON_DEPEND="*"
@@ -10,25 +10,22 @@ RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
inherit eutils python toolchain-funcs
-MY_P="${P/_pre/-snapshot-}"
-
DESCRIPTION="Python extension module generator for C and C++ libraries"
HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${P}.tar.gz"
LICENSE="|| ( GPL-2 GPL-3 sip )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="debug doc"
-S="${WORKDIR}/${MY_P}"
-
DEPEND=""
RDEPEND=""
src_prepare() {
- epatch "${FILESDIR}/${PN}-4.9.3-darwin.patch"
- sed -i 's/-O2//g' specs/* || die
+ epatch "${FILESDIR}"/${PN}-4.9.3-darwin.patch
+ sed -i -e 's/-O2//g' specs/* || die
+
python_copy_sources
}