summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-06-21 18:43:17 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-06-21 18:43:17 +0000
commitcea0e04b95bcb190486432270ef7a1fb6e7d27bb (patch)
treef0b79248ca7e28ca4029a5ea01577798741d4b8e /dev-python/sip
parentVersion bump (diff)
downloadgentoo-2-cea0e04b95bcb190486432270ef7a1fb6e7d27bb.tar.gz
gentoo-2-cea0e04b95bcb190486432270ef7a1fb6e7d27bb.tar.bz2
gentoo-2-cea0e04b95bcb190486432270ef7a1fb6e7d27bb.zip
Version bump
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/ChangeLog7
-rw-r--r--dev-python/sip/sip-4.13.3.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 17dc8d5acaef..efae3acf4f63 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.215 2012/05/23 04:50:03 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.216 2012/06/21 18:43:17 hwoarang Exp $
+
+*sip-4.13.3 (21 Jun 2012)
+
+ 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +sip-4.13.3.ebuild:
+ Version bump
23 May 2012; Jeff Horelick <jdhore@gentoo.org> sip-4.13.2-r1.ebuild:
marked x86 per bug 412929
diff --git a/dev-python/sip/sip-4.13.3.ebuild b/dev-python/sip/sip-4.13.3.ebuild
new file mode 100644
index 000000000000..b1e3b971d289
--- /dev/null
+++ b/dev-python/sip/sip-4.13.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.13.3.ebuild,v 1.1 2012/06/21 18:43:17 hwoarang Exp $
+
+EAPI="4"
+PYTHON_DEPEND="*"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
+
+inherit eutils python toolchain-funcs
+
+DESCRIPTION="Python extension module generator for C and C++ libraries"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 sip )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug doc"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.9.3-darwin.patch
+ sed -i -e 's/-O2//g' specs/* || die
+
+ python_src_prepare
+}
+
+src_configure() {
+ configuration() {
+ local myconf=("$(PYTHON)"
+ configure.py
+ --bindir="${EPREFIX}/usr/bin"
+ --destdir="${EPREFIX}$(python_get_sitedir)"
+ --incdir="${EPREFIX}$(python_get_includedir)"
+ --sipdir="${EPREFIX}/usr/share/sip"
+ $(use debug && echo --debug)
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ LINK="$(tc-getCXX)"
+ LINK_SHLIB="$(tc-getCXX)"
+ CFLAGS="${CFLAGS}"
+ CXXFLAGS="${CXXFLAGS}"
+ LFLAGS="${LDFLAGS}"
+ STRIP=":")
+ echo "${myconf[@]}"
+ "${myconf[@]}"
+ }
+ python_execute_function -s configuration
+}
+
+src_install() {
+ python_src_install
+
+ dodoc NEWS
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize sipconfig.py sipdistutils.py
+
+ ewarn "When updating dev-python/sip, you usually need to rebuild packages that depend on it,"
+ ewarn "such as PyQt4, qscintilla-python and pykde4. If you have app-portage/gentoolkit"
+ ewarn "installed, you can find these packages with \`equery d dev-python/sip\`."
+}
+
+pkg_postrm() {
+ python_mod_cleanup sipconfig.py sipdistutils.py
+}