summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2015-06-29 21:10:54 +0000
committerDavide Pesavento <pesa@gentoo.org>2015-06-29 21:10:54 +0000
commit8197243809d9d200958f7aa2e181d0082a9f96e5 (patch)
tree9e9005315a3f86a39d2a12d890db27277adf2c02 /dev-python/sip
parentDrop old version. As of now, sparc no longer has a stable PyQt4, see bug #523... (diff)
downloadgentoo-2-8197243809d9d200958f7aa2e181d0082a9f96e5.tar.gz
gentoo-2-8197243809d9d200958f7aa2e181d0082a9f96e5.tar.bz2
gentoo-2-8197243809d9d200958f7aa2e181d0082a9f96e5.zip
Drop old version. As of now, sparc no longer has a stable sip, see bug #523322 comment #15.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xDADED6B2671CB57D!)
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/ChangeLog7
-rw-r--r--dev-python/sip/files/sip-4.9.3-darwin.patch41
-rw-r--r--dev-python/sip/sip-4.15.3.ebuild113
3 files changed, 6 insertions, 155 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 472b6e110c34..180312514381 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.310 2015/06/17 17:26:25 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.311 2015/06/29 21:10:54 pesa Exp $
+
+ 29 Jun 2015; Davide Pesavento <pesa@gentoo.org> -files/sip-4.9.3-darwin.patch,
+ -sip-4.15.3.ebuild:
+ Drop old version. As of now, sparc no longer has a stable sip, see bug #523322
+ comment #15.
17 Jun 2015; Davide Pesavento <pesa@gentoo.org> -sip-4.16.7.ebuild:
Drop version that is not going to get stabilized.
diff --git a/dev-python/sip/files/sip-4.9.3-darwin.patch b/dev-python/sip/files/sip-4.9.3-darwin.patch
deleted file mode 100644
index c82b727f3d2f..000000000000
--- a/dev-python/sip/files/sip-4.9.3-darwin.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Don't require a framework builds, and produce .bundle files
-
---- siputils.py
-+++ siputils.py
-@@ -818,8 +818,6 @@
- """
- if self.generator in ("MSVC", "MSVC.NET", "BMAKE"):
- plib = clib + ".lib"
-- elif sys.platform == "darwin" and framework:
-- plib = "-framework " + clib
- else:
- plib = "-l" + clib
-
-@@ -836,8 +834,6 @@
-
- if self.generator in ("MSVC", "MSVC.NET", "BMAKE"):
- prl_name = os.path.join(self.config.qt_lib_dir, clib + ".prl")
-- elif sys.platform == "darwin" and framework:
-- prl_name = os.path.join(self.config.qt_lib_dir, clib + ".framework", clib + ".prl")
- else:
- prl_name = os.path.join(self.config.qt_lib_dir, "lib" + clib + ".prl")
-
-@@ -1396,9 +1392,6 @@
- # 'real_prefix' exists if virtualenv is being used.
- dl = getattr(sys, 'real_prefix', sys.exec_prefix).split(os.sep)
-
-- if "Python.framework" not in dl:
-- error("SIP requires Python to be built as a framework")
--
- self.LFLAGS.append("-undefined dynamic_lookup")
-
- Makefile.finalise(self)
-@@ -1478,7 +1471,7 @@
- if sys.platform == "win32":
- ext = "pyd"
- elif sys.platform == "darwin":
-- ext = "so"
-+ ext = "bundle"
- elif sys.platform == "cygwin":
- ext = "dll"
- else:
diff --git a/dev-python/sip/sip-4.15.3.ebuild b/dev-python/sip/sip-4.15.3.ebuild
deleted file mode 100644
index 45d6beba1f46..000000000000
--- a/dev-python/sip/sip-4.15.3.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.15.3.ebuild,v 1.13 2015/04/08 08:04:59 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit eutils python-r1 toolchain-funcs
-
-DESCRIPTION="Python extension module generator for C and C++ libraries"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro https://pypi.python.org/pypi/SIP"
-LICENSE="|| ( GPL-2 GPL-3 SIP )"
-
-if [[ ${PV} == *9999* ]]; then
- # live version from mercurial repo
- EHG_REPO_URI="http://www.riverbankcomputing.com/hg/sip"
- inherit mercurial
-elif [[ ${PV} == *_pre* ]]; then
- # development snapshot
- HG_REVISION=
- MY_P=${PN}-${PV%_pre*}-snapshot-${HG_REVISION}
- SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${MY_P}.tar.gz"
- S=${WORKDIR}/${MY_P}
-else
- # official release
- SRC_URI="mirror://sourceforge/pyqt/${P}.tar.gz"
-fi
-
-# Sub-slot based on SIP_API_MAJOR_NR from siplib/sip.h.in
-SLOT="0/10"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="debug doc"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}"
-
-[[ ${PV} == *9999* ]] && DEPEND+="
- =dev-lang/python-2*
- sys-devel/bison
- sys-devel/flex
- doc? ( dev-python/sphinx[$(python_gen_usedep 'python2*')] )
-"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.9.3-darwin.patch
-
- if [[ ${PV} == *9999* ]]; then
- python2 build.py prepare || die
- if use doc; then
- python2 build.py doc || die
- fi
- fi
-
- # Sub-slot sanity check
- local sub_slot=${SLOT#*/}
- local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h.in)
- if [[ ${sub_slot} != ${sip_api_major_nr} ]]; then
- eerror
- eerror "Ebuild sub-slot (${sub_slot}) does not match SIP_API_MAJOR_NR (${sip_api_major_nr})"
- eerror "Please update SLOT variable as follows:"
- eerror " SLOT=\"${SLOT%%/*}/${sip_api_major_nr}\""
- eerror
- die "sub-slot sanity check failed"
- fi
-
- python_copy_sources
-}
-
-src_configure() {
- configuration() {
- local myconf=(
- "${PYTHON}" configure.py
- --bindir="${EPREFIX}/usr/bin"
- --destdir="$(python_get_sitedir)"
- --incdir="$(python_get_includedir)"
- --sipdir="${EPREFIX}/usr/share/sip"
- $(use debug && echo --debug)
- AR="$(tc-getAR) cqs"
- CC="$(tc-getCC)"
- CFLAGS="${CFLAGS}"
- CFLAGS_RELEASE=
- CXX="$(tc-getCXX)"
- CXXFLAGS="${CXXFLAGS}"
- CXXFLAGS_RELEASE=
- LINK="$(tc-getCXX)"
- LINK_SHLIB="$(tc-getCXX)"
- LFLAGS="${LDFLAGS}"
- LFLAGS_RELEASE=
- RANLIB=
- STRIP=
- )
- echo "${myconf[@]}"
- "${myconf[@]}"
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- emake DESTDIR="${D}" install
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-
- dodoc NEWS
- use doc && dohtml -r doc/html/*
-}