summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-07-25 21:12:17 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-07-25 21:12:17 +0000
commit170db6fe346efb0053e87d02e66222fcabdc3ce3 (patch)
treebb1fec9dbb7433d39afb33e53e23d219bf6d4aa4 /dev-python/sip/sip-3.3.2.ebuild
parentAdded LICENSE (diff)
downloadgentoo-2-170db6fe346efb0053e87d02e66222fcabdc3ce3.tar.gz
gentoo-2-170db6fe346efb0053e87d02e66222fcabdc3ce3.tar.bz2
gentoo-2-170db6fe346efb0053e87d02e66222fcabdc3ce3.zip
new version
Diffstat (limited to 'dev-python/sip/sip-3.3.2.ebuild')
-rw-r--r--dev-python/sip/sip-3.3.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sip/sip-3.3.2.ebuild b/dev-python/sip/sip-3.3.2.ebuild
new file mode 100644
index 000000000000..b0bbeb3bb498
--- /dev/null
+++ b/dev-python/sip/sip-3.3.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-3.3.2.ebuild,v 1.1 2002/07/25 21:12:17 verwilst Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+SRC_URI="http://www.riverbankcomputing.co.uk/download/sip/${P}.tar.gz"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="x86"
+DEPEND="virtual/glibc
+ >=dev-lang/python-2.2.1"
+
+src_compile(){
+
+ cd ${S}
+ chmod +x build.py
+ mkdir -p ${D}/usr/bin
+ mkdir -p ${D}/usr/lib/python2.2/site-packages
+ python build.py -l qt-mt -b ${D}/usr/bin -d ${D}/usr/lib/python2.2/site-packages
+ make
+}
+
+src_install() {
+
+ cd ${S}/siplib
+ mv Makefile Makefile.orig
+ sed s:"cp sip.h /usr/include/python2.2":"cp sip.h /var/tmp/portage/sip-3.3.2/image/usr/include/python2.2": Makefile.orig > Makefile
+ mv Makefile Makefile.orig2
+ sed s:"cp sipQt.h /usr/include/python2.2":"cp sipQt.h /var/tmp/portage/sip-3.3.2/image/usr/include/python2.2": Makefile.orig2 > Makefile
+ cd ${S}
+ mkdir -p ${D}/usr/include/python2.2
+ make DESTDIR=${D} install || die
+ dodoc NEWS README THANKS
+
+}