summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2013-02-28 17:31:13 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2013-02-28 17:31:13 +0000
commitc69762a29db3285a2d74e96c1dfc2abf98f92c28 (patch)
treef594186f360e56613483a4c0fa9273a86679866f /dev-python/requests-cache
parentDon't call pkg-config directly, in order not to break cross compilation. (diff)
downloadgentoo-2-c69762a29db3285a2d74e96c1dfc2abf98f92c28.tar.gz
gentoo-2-c69762a29db3285a2d74e96c1dfc2abf98f92c28.tar.bz2
gentoo-2-c69762a29db3285a2d74e96c1dfc2abf98f92c28.zip
Import based on dev-python/requests.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/ChangeLog9
-rw-r--r--dev-python/requests-cache/metadata.xml12
-rw-r--r--dev-python/requests-cache/requests-cache-0.3.0.ebuild23
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/requests-cache/ChangeLog b/dev-python/requests-cache/ChangeLog
new file mode 100644
index 000000000000..859769572f3a
--- /dev/null
+++ b/dev-python/requests-cache/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/requests-cache
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests-cache/ChangeLog,v 1.1 2013/02/28 17:31:13 zx2c4 Exp $
+
+*requests-cache-0.3.0 (28 Feb 2013)
+
+ 28 Feb 2013; Jason A. Donenfeld <zx2c4@gentoo.org> +metadata.xml,
+ +requests-cache-0.3.0.ebuild:
+ Import based on dev-python/requests.
diff --git a/dev-python/requests-cache/metadata.xml b/dev-python/requests-cache/metadata.xml
new file mode 100644
index 000000000000..2b10aee102a4
--- /dev/null
+++ b/dev-python/requests-cache/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">requests-cache</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/requests-cache/requests-cache-0.3.0.ebuild b/dev-python/requests-cache/requests-cache-0.3.0.ebuild
new file mode 100644
index 000000000000..a240f4c79360
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-0.3.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests-cache/requests-cache-0.3.0.ebuild,v 1.1 2013/02/28 17:31:13 zx2c4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library for human beings"
+HOMEPAGE="Persistent cache for requests library"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/requests-1.1.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst HISTORY.rst )