summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-07-04 12:23:37 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-07-04 12:23:37 +0000
commitfeee8b7aaf49b0f6237a3de020e4294d9b3c73ec (patch)
treee08aae6d9488627e7ffc2e1c44657533315686e9 /dev-python/reportlab
parentremoving old reportlab (diff)
downloadgentoo-2-feee8b7aaf49b0f6237a3de020e4294d9b3c73ec.tar.gz
gentoo-2-feee8b7aaf49b0f6237a3de020e4294d9b3c73ec.tar.bz2
gentoo-2-feee8b7aaf49b0f6237a3de020e4294d9b3c73ec.zip
add patches
Diffstat (limited to 'dev-python/reportlab')
-rw-r--r--dev-python/reportlab/Manifest4
-rw-r--r--dev-python/reportlab/files/1.14/setup.py55
-rw-r--r--dev-python/reportlab/files/1.17/setup.py55
-rw-r--r--dev-python/reportlab/reportlab-1.17-r1.ebuild4
4 files changed, 115 insertions, 3 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index a460913c06df..fc0256aa4d78 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -1,8 +1,10 @@
MD5 d71e510af316336cee71028e30d263ea reportlab-1.14.ebuild 822
MD5 55f5f54081454994c1c9ae75ba426bb7 reportlab-1.17.ebuild 824
-MD5 04fdd8f3d9bba5f0778dbe17551620a8 reportlab-1.17-r1.ebuild 1017
+MD5 ea5e892b9f367e12550c5dd52447bec5 reportlab-1.17-r1.ebuild 1019
MD5 62881102f29401d6271a92eaacb665c1 ChangeLog 1550
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
MD5 d5f5c0582f5df6e146b770ba6262cae9 files/digest-reportlab-1.17 64
MD5 ae52d6e28f68d0a56dad9fdc2c295b92 files/digest-reportlab-1.14 64
MD5 d5f5c0582f5df6e146b770ba6262cae9 files/digest-reportlab-1.17-r1 64
+MD5 f8fae2ab18041c7466c36685624a2192 files/1.14/setup.py 2887
+MD5 cdbafc7e047b69becba3bddfef8a61da files/1.17/setup.py 2887
diff --git a/dev-python/reportlab/files/1.14/setup.py b/dev-python/reportlab/files/1.14/setup.py
new file mode 100644
index 000000000000..aae40634a142
--- /dev/null
+++ b/dev-python/reportlab/files/1.14/setup.py
@@ -0,0 +1,55 @@
+#! /usr/bin/env python
+
+from os import chdir, stat
+from distutils.core import setup, Extension
+
+setup (# Distribution meta-data
+ name = "ReportLab",
+ version = "1.14",
+ description = "Tools for generating printable PDF documents from any data source.",
+ author = "ReportLab Inc.",
+# author_email = "",
+ license = """
+#####################################################################################
+#
+# Copyright (c) 2000-2001, ReportLab Inc.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without modification,
+# are permitted provided that the following conditions are met:
+#
+# * Redistributions of source code must retain the above copyright notice,
+# this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright notice,
+# this list of conditions and the following disclaimer in the documentation
+# and/or other materials provided with the distribution.
+# * Neither the name of the company nor the names of its contributors may be
+# used to endorse or promote products derived from this software without
+# specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+# ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+# IN NO EVENT SHALL THE OFFICERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+# INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
+# TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER
+# IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+# SUCH DAMAGE.
+#
+#####################################################################################""",
+ long_description = "Tools for generating printable PDF documents from any data source.",
+ url = "http://www.reportlab.com/",
+ extra_path = "reportlab",
+ package_dir = { '':'.' },
+ packages = [ 'extensions',
+ 'graphics', 'graphics/charts', 'graphics/widgets',
+ 'lib', 'pdfbase', 'pdfgen', 'platypus',
+ 'test', 'tools', 'tools/docco', 'tools/py2pdf',
+ 'tools/pythonpoint', 'tools/pythonpoint/styles',
+ '.',
+ ],
+#./fonts
+ )
+
diff --git a/dev-python/reportlab/files/1.17/setup.py b/dev-python/reportlab/files/1.17/setup.py
new file mode 100644
index 000000000000..2ca3d033e8d3
--- /dev/null
+++ b/dev-python/reportlab/files/1.17/setup.py
@@ -0,0 +1,55 @@
+#! /usr/bin/env python
+
+from os import chdir, stat
+from distutils.core import setup, Extension
+
+setup (# Distribution meta-data
+ name = "ReportLab",
+ version = "1.17",
+ description = "Tools for generating printable PDF documents from any data source.",
+ author = "ReportLab Inc.",
+# author_email = "",
+ license = """
+#####################################################################################
+#
+# Copyright (c) 2000-2001, ReportLab Inc.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without modification,
+# are permitted provided that the following conditions are met:
+#
+# * Redistributions of source code must retain the above copyright notice,
+# this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright notice,
+# this list of conditions and the following disclaimer in the documentation
+# and/or other materials provided with the distribution.
+# * Neither the name of the company nor the names of its contributors may be
+# used to endorse or promote products derived from this software without
+# specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+# ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+# IN NO EVENT SHALL THE OFFICERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+# INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
+# TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER
+# IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+# SUCH DAMAGE.
+#
+#####################################################################################""",
+ long_description = "Tools for generating printable PDF documents from any data source.",
+ url = "http://www.reportlab.com/",
+ extra_path = "reportlab",
+ package_dir = { '':'.' },
+ packages = [ 'extensions',
+ 'graphics', 'graphics/charts', 'graphics/widgets',
+ 'lib', 'pdfbase', 'pdfgen', 'platypus',
+ 'test', 'tools', 'tools/docco', 'tools/py2pdf',
+ 'tools/pythonpoint', 'tools/pythonpoint/styles',
+ '.',
+ ],
+#./fonts
+ )
+
diff --git a/dev-python/reportlab/reportlab-1.17-r1.ebuild b/dev-python/reportlab/reportlab-1.17-r1.ebuild
index 190c694588bc..64e821909203 100644
--- a/dev-python/reportlab/reportlab-1.17-r1.ebuild
+++ b/dev-python/reportlab/reportlab-1.17-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/reportlab-1.17-r1.ebuild,v 1.1 2003/07/04 12:16:11 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/reportlab-1.17-r1.ebuild,v 1.2 2003/07/04 12:23:30 liquidx Exp $
#goofy tarball versioning
vmaj=${PV%%.*}
@@ -16,7 +16,7 @@ HOMEPAGE="http://www.reportlab.com/"
DEPEND="virtual/python
>=sys-libs/zlib-0.95
dev-python/Imaging
- sys-apps/sed-4"
+ >=sys-apps/sed-4"
SLOT="0"
LICENSE="as-is"
KEYWORDS="~x86 ~sparc ~alpha"