summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-01-06 21:31:37 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-01-06 21:31:37 +0000
commit3cb8ed82480b52bd611875c8f77420a35caeefb5 (patch)
treee28a69e9db137cf7be543bb0baeaaa8ab0f7cf99 /dev-python/qscintilla
parentUpdated 5.5.20 dep on java-config-2.0.31 (diff)
downloadgentoo-2-3cb8ed82480b52bd611875c8f77420a35caeefb5.tar.gz
gentoo-2-3cb8ed82480b52bd611875c8f77420a35caeefb5.tar.bz2
gentoo-2-3cb8ed82480b52bd611875c8f77420a35caeefb5.zip
Added qt3 to inherit, fixed bug #140345. Some cleanups.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'dev-python/qscintilla')
-rw-r--r--dev-python/qscintilla/ChangeLog8
-rw-r--r--dev-python/qscintilla/qscintilla-1.7.1.ebuild38
2 files changed, 24 insertions, 22 deletions
diff --git a/dev-python/qscintilla/ChangeLog b/dev-python/qscintilla/ChangeLog
index fcaf1f286aef..38a912deb414 100644
--- a/dev-python/qscintilla/ChangeLog
+++ b/dev-python/qscintilla/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/qscintilla
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla/ChangeLog,v 1.67 2006/12/26 22:38:00 dev-zero Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla/ChangeLog,v 1.68 2007/01/06 21:31:37 dev-zero Exp $
+
+ 06 Jan 2007; Tiziano Müller <dev-zero@gentoo.org>
+ qscintilla-1.7.1.ebuild:
+ Added qt3 to inherit, fixed bug #140345. Some cleanups.
*qscintilla-1.7.1 (26 Dec 2006)
diff --git a/dev-python/qscintilla/qscintilla-1.7.1.ebuild b/dev-python/qscintilla/qscintilla-1.7.1.ebuild
index 38668678344c..c4fc3c3fea81 100644
--- a/dev-python/qscintilla/qscintilla-1.7.1.ebuild
+++ b/dev-python/qscintilla/qscintilla-1.7.1.ebuild
@@ -1,55 +1,53 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla/qscintilla-1.7.1.ebuild,v 1.1 2006/12/26 22:38:00 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla/qscintilla-1.7.1.ebuild,v 1.2 2007/01/06 21:31:37 dev-zero Exp $
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs qt3
-QSCINTILLA_MAJOR_VER="1"
SCINTILLA_VER="1.71"
MY_P="${PN/qs/QS}-${SCINTILLA_VER}-gpl-${PV}"
MY_P=${MY_P/_pre/snapshot-}
-S=${WORKDIR}/${MY_P}
DESCRIPTION="QScintilla is a port to Qt of Neil Hodgson's Scintilla C++ editor class."
HOMEPAGE="http://www.riverbankcomputing.co.uk/qscintilla/"
-#SRC_URI="http://www.river-bank.demon.co.uk/download/snapshots/QScintilla/${MY_P}.tar.gz"
SRC_URI="http://www.riverbankcomputing.com/Downloads/QScintilla1/${MY_P}.tar.gz"
-#SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc"
-DEPEND="=x11-libs/qt-3*"
+DEPEND="$(qt_min_version 3.3)"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
- cd ${S}/qt
+ cd "${S}/qt"
sed -i -e "s:DESTDIR = \$(QTDIR)/lib:DESTDIR = lib:" qscintilla.pro
echo -e "\nQMAKE_CFLAGS_RELEASE=${CFLAGS} -w\nQMAKE_CXXFLAGS_RELEASE=${CXXFLAGS} -w\nQMAKE_LFLAGS_RELEASE=${LDFLAGS}" >> qscintilla.pro
- ${QTDIR}/bin/qmake -o Makefile qscintilla.pro
+ ${QTDIR}/bin/qmake -o Makefile qscintilla.pro || die "qmake qscintilla failed"
- cd ${S}
- epatch ${FILESDIR}/${P}.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${P}.patch"
- cd ${S}/designer
+ cd "${S}/designer"
echo -e "\nQMAKE_CFLAGS_RELEASE=${CFLAGS} -w\nQMAKE_CXXFLAGS_RELEASE=${CXXFLAGS} -w\nQMAKE_LFLAGS_RELEASE=${LDFLAGS}" >> designer.pro
- ${QTDIR}/bin/qmake -o Makefile designer.pro
+ ${QTDIR}/bin/qmake -o Makefile designer.pro || die "qmake designer failed"
}
src_compile() {
- cd ${S}/qt
- make all staticlib CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" || die "make failed"
- cd ${S}/designer
+ cd "${S}/qt"
+ emake all staticlib CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" || die "emake failed"
+ cd "${S}/designer"
dodir ${QTDIR}/plugins/designer
- make
+ emake || die "emake designer failed"
}
src_install() {
- dodoc ChangeLog LICENSE NEWS README*
+ dodoc ChangeLog NEWS README*
dodir ${ROOT}/usr/{include,$(get_libdir),share/qscintilla/translations}
cd ${S}/qt
cp qextscintilla*.h "${D}/usr/include"