summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-30 22:32:06 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-30 22:32:06 +0000
commite15ce90110b13858ae3c8bb1fbbd279863123c9e (patch)
treeec42e8e3cb27d67e3afc820a7b70a9ae9bd41e1a /dev-python/pywebkitgtk
parentFix compatibility with Python 2.6 (without fixing of deprecation warnings) (b... (diff)
downloadgentoo-2-e15ce90110b13858ae3c8bb1fbbd279863123c9e.tar.gz
gentoo-2-e15ce90110b13858ae3c8bb1fbbd279863123c9e.tar.bz2
gentoo-2-e15ce90110b13858ae3c8bb1fbbd279863123c9e.zip
Install .pth file (bug #283271). Add linking against libgthread-2.0 (bug #283271).
(Portage version: 14173-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pywebkitgtk')
-rw-r--r--dev-python/pywebkitgtk/ChangeLog9
-rw-r--r--dev-python/pywebkitgtk/pywebkitgtk-1.1.6-r1.ebuild52
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-python/pywebkitgtk/ChangeLog b/dev-python/pywebkitgtk/ChangeLog
index 62c34e515985..ba7a54ad5885 100644
--- a/dev-python/pywebkitgtk/ChangeLog
+++ b/dev-python/pywebkitgtk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pywebkitgtk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/ChangeLog,v 1.3 2009/08/29 02:25:11 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/ChangeLog,v 1.4 2009/08/30 22:32:06 arfrever Exp $
+
+*pywebkitgtk-1.1.6-r1 (30 Aug 2009)
+
+ 30 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pywebkitgtk-1.1.6-r1.ebuild:
+ Install .pth file (bug #283271). Add linking against libgthread-2.0 (bug
+ #283271).
*pywebkitgtk-1.1.6 (29 Aug 2009)
diff --git a/dev-python/pywebkitgtk/pywebkitgtk-1.1.6-r1.ebuild b/dev-python/pywebkitgtk/pywebkitgtk-1.1.6-r1.ebuild
new file mode 100644
index 000000000000..a796ef06592c
--- /dev/null
+++ b/dev-python/pywebkitgtk/pywebkitgtk-1.1.6-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/pywebkitgtk-1.1.6-r1.ebuild,v 1.1 2009/08/30 22:32:06 arfrever Exp $
+
+EAPI="2"
+
+NEED_PYTHON="2.4"
+PYTHON_DEFINE_DEFAULT_FUNCTIONS="1"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit autotools python
+
+DESCRIPTION="Python bindings for the WebKit GTK+ port."
+HOMEPAGE="http://code.google.com/p/pywebkitgtk/"
+SRC_URI="http://pywebkitgtk.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pygobject:2
+ dev-python/pygtk:2
+ dev-python/sexy-python
+ x11-libs/libsexy
+ dev-libs/libxslt
+ >=net-libs/webkit-gtk-1.1.5"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_prepare() {
+ sed -e "s:libxslt,:libxslt, gthread-2.0:" -i configure.ac
+ AT_M4DIR="m4" eautoreconf
+ python_src_prepare
+}
+
+src_install() {
+ python_need_rebuild
+
+ python_execute_function -d -s
+
+ # Fix importing of webkit (bug #283271).
+ create_webkit_pth() {
+ dodir $(python_get_sitedir)
+ echo "webkit-1.0" > "${D}$(python_get_sitedir)/webkit.pth"
+ }
+ python_execute_function -q create_webkit_pth
+
+ dodoc AUTHORS MAINTAINERS NEWS README || die "dodoc failed"
+}