summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2005-11-24 21:28:05 +0000
committerMarien Zwart <marienz@gentoo.org>2005-11-24 21:28:05 +0000
commit6fc64208ad6bac7dca8770cb38aa511d587526c2 (patch)
tree4eff793d987d5525dab35a086932de06ccd1ac59 /dev-python/pytz
parentVersion bump (diff)
downloadgentoo-2-6fc64208ad6bac7dca8770cb38aa511d587526c2.tar.gz
gentoo-2-6fc64208ad6bac7dca8770cb38aa511d587526c2.tar.bz2
gentoo-2-6fc64208ad6bac7dca8770cb38aa511d587526c2.zip
New ebuild, closes bug #111513.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-python/pytz')
-rw-r--r--dev-python/pytz/ChangeLog10
-rw-r--r--dev-python/pytz/Manifest3
-rw-r--r--dev-python/pytz/files/digest-pytz-2005m1
-rw-r--r--dev-python/pytz/metadata.xml17
-rw-r--r--dev-python/pytz/pytz-2005m.ebuild23
5 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pytz/ChangeLog b/dev-python/pytz/ChangeLog
new file mode 100644
index 000000000000..043d8a77ef04
--- /dev/null
+++ b/dev-python/pytz/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pytz
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytz/ChangeLog,v 1.1 2005/11/24 21:28:05 marienz Exp $
+
+*pytz-2005m (24 Nov 2005)
+
+ 24 Nov 2005; Marien Zwart <marienz@gentoo.org> +metadata.xml,
+ +pytz-2005m.ebuild:
+ New ebuild, based on an ebuild from André Malo <nd@perlig.de> (bug #111513)
+
diff --git a/dev-python/pytz/Manifest b/dev-python/pytz/Manifest
new file mode 100644
index 000000000000..41897d95c32d
--- /dev/null
+++ b/dev-python/pytz/Manifest
@@ -0,0 +1,3 @@
+MD5 f1530e5cf3ac10fb9412d0f9ce55ccbf files/digest-pytz-2005m 63
+MD5 8c2f4c7632f1c07d9e130476530fa978 metadata.xml 633
+MD5 8ae776f34597271d46dc6c94eef6c158 pytz-2005m.ebuild 507
diff --git a/dev-python/pytz/files/digest-pytz-2005m b/dev-python/pytz/files/digest-pytz-2005m
new file mode 100644
index 000000000000..9fdc8e1dfb64
--- /dev/null
+++ b/dev-python/pytz/files/digest-pytz-2005m
@@ -0,0 +1 @@
+MD5 d0b8fd7e4a5be5fc763cb22044fba854 pytz-2005m.tar.bz2 108528
diff --git a/dev-python/pytz/metadata.xml b/dev-python/pytz/metadata.xml
new file mode 100644
index 000000000000..e96b9d543374
--- /dev/null
+++ b/dev-python/pytz/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<maintainer>
+ <email>marienz@gentoo.org</email>
+</maintainer>
+<longdescription>
+ pytz brings the Olson tz database into Python. This library allows
+ accurate and cross platform timezone calculations using Python 2.3
+ or higher. It also solves the issue of ambiguous times at the end of
+ daylight savings, which you can read more about in the Python
+ Library Reference (datetime.tzinfo).
+
+ Amost all (over 540) of the Olson timezones are supported.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/pytz/pytz-2005m.ebuild b/dev-python/pytz/pytz-2005m.ebuild
new file mode 100644
index 000000000000..43750e2fe355
--- /dev/null
+++ b/dev-python/pytz/pytz-2005m.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytz/pytz-2005m.ebuild,v 1.1 2005/11/24 21:28:05 marienz Exp $
+
+inherit distutils
+
+DESCRIPTION="World Timezone Definitions for Python"
+HOMEPAGE="http://pytz.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${PV}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ !<=dev-python/matplotlib-0.82"
+
+DOCS="CHANGES.txt"
+
+src_test() {
+ PYTHONPATH=. ${python} pytz/tests/test_tzinfo.py || die "test failed"
+}