summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-25 17:25:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-25 17:25:55 +0000
commit01ca4c4b287e688600486c1b0ccc49146e1174e8 (patch)
tree476914c411d32c7d9f916f1210c942338eaeafa0 /dev-python/python-scw
parentStable for HPPA (bug #294256). (diff)
downloadgentoo-2-01ca4c4b287e688600486c1b0ccc49146e1174e8.tar.gz
gentoo-2-01ca4c4b287e688600486c1b0ccc49146e1174e8.tar.bz2
gentoo-2-01ca4c4b287e688600486c1b0ccc49146e1174e8.zip
Fix dependencies. Set SUPPORT_PYTHON_ABIS.
(Portage version: 2.2.0_alpha10_p8/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-scw')
-rw-r--r--dev-python/python-scw/ChangeLog8
-rw-r--r--dev-python/python-scw/python-scw-0.4.7.ebuild20
2 files changed, 20 insertions, 8 deletions
diff --git a/dev-python/python-scw/ChangeLog b/dev-python/python-scw/ChangeLog
index 3c2473c78a20..ddbee22868b0 100644
--- a/dev-python/python-scw/ChangeLog
+++ b/dev-python/python-scw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/python-scw
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-scw/ChangeLog,v 1.3 2009/02/15 23:05:49 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-scw/ChangeLog,v 1.4 2010/12/25 17:25:55 arfrever Exp $
+
+ 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-scw-0.4.7.ebuild:
+ Fix dependencies. Set SUPPORT_PYTHON_ABIS.
15 Feb 2009; Patrick Lauer <patrick@gentoo.org> python-scw-0.4.7.ebuild:
Adding ~amd64 keyword
diff --git a/dev-python/python-scw/python-scw-0.4.7.ebuild b/dev-python/python-scw/python-scw-0.4.7.ebuild
index 9e0d7bb9dd7b..c44d2e196c73 100644
--- a/dev-python/python-scw/python-scw-0.4.7.ebuild
+++ b/dev-python/python-scw/python-scw-0.4.7.ebuild
@@ -1,22 +1,30 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-scw/python-scw-0.4.7.ebuild,v 1.3 2009/02/15 23:05:49 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-scw/python-scw-0.4.7.ebuild,v 1.4 2010/12/25 17:25:55 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
inherit python
DESCRIPTION="Python binding for Scw."
HOMEPAGE="http://scwwidgets.googlepages.com/"
SRC_URI="http://scwwidgets.googlepages.com/${P}.tar.gz "
+
LICENSE="LGPL-2"
SLOT="0"
-
KEYWORDS="~amd64 ~x86"
IUSE=""
+
DEPEND=">=dev-python/pygtk-2.4
>=x11-libs/scw-0.4.0"
+RDEPEND="${DEPEND}"
src_install() {
- python_need_rebuild
- make DESTDIR="${D}" install || die
- dodoc README NEWS ChangeLog AUTHORS
+ python_src_install
+ python_clean_installation_image
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
}